none
SSIS Version issue running on command line RRS feed

  • Question

  • I have a Project created in VS2010 that I want to run on SQL2012.  The Project deploys to SSMS2012 fine.  Runs without error.  I converted the Project to a package so I can run it from the command line.  When I run it from the command line I get an error that says it is an older version.  XML says package format 6 but when I run it on the command line it thinks I am trying to run it against 2008 which is 3 but I am not.

    This server was a 2008 server that was upgraded.  Is it possible that there is a dll or something that was not upgraded that make it still think it is a 2008?  If so what is it and how do I change it?  Could it be just a path issue.  I have to run it from a particular path.  I am running it from the default path location in users.

     
    Saturday, February 21, 2015 12:21 AM

Answers

  • Odds are that it is picking up the 2008 dtexec. You can verify by typing "where dtexec" from a command prompt

    To resolve the issue, provide a fully qualified path to the executable

    Default 64 bit path

    C:\Program Files\Microsoft SQL Server\110\DTS\Binn\DTExec.exe

    Default 32 bit path

    C:\Program Files (x86)\Microsoft SQL Server\110\DTS\Binn\DTExec.exe


    • Marked as answer by SQLMelodyMVP Saturday, February 21, 2015 3:06 AM
    Saturday, February 21, 2015 1:44 AM
    Answerer