none
WorkflowDesigner & Microsoft.VisualStudio.SharePoint.WorkflowDesignerSupport

    Question

  • I have the following configuration:

    When I try to open SharePoint project with custom workflow actions I get the following error: 

    -------------------------

    Workflow Designer
    -------------------------
    CompositionException:
    The composition produced a single composition error. The root cause is provided below. Review the CompositionException.Errors property for more detailed information.

    1) Could not load file or assembly 'Microsoft.VisualStudio.SharePoint.WorkflowDesignerSupport, Version=14.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

    Resulting in: An exception occurred while trying to create an instance of type 'Microsoft.VisualStudio.SharePoint.WorkflowExtensions.SharePointListService'.

    Resulting in: Cannot activate part 'Microsoft.VisualStudio.SharePoint.WorkflowExtensions.SharePointListService'.
    Element: Microsoft.VisualStudio.SharePoint.WorkflowExtensions.SharePointListService -->  Microsoft.VisualStudio.SharePoint.WorkflowExtensions.SharePointListService -->  DirectoryCatalog (Path="C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\WorkflowDesigner")

    Resulting in: Cannot get export 'Microsoft.VisualStudio.SharePoint.WorkflowExtensions.SharePointListService (ContractName="Microsoft.SharePoint.DesignTime.Activities.Design.Services.ISharePointListService")' from part 'Microsoft.VisualStudio.SharePoint.WorkflowExtensions.SharePointListService'.
    Element: Microsoft.VisualStudio.SharePoint.WorkflowExtensions.SharePointListService (ContractName="Microsoft.SharePoint.DesignTime.Activities.Design.Services.ISharePointListService") -->  Microsoft.VisualStudio.SharePoint.WorkflowExtensions.SharePointListService -->  DirectoryCatalog (Path="C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\WorkflowDesigner")

    -------------------------
       at System.ComponentModel.Composition.Hosting.CompositionServices.GetExportedValueFromComposedPart(ImportEngine engine, ComposablePart part, ExportDefinition definition)
       at System.ComponentModel.Composition.Hosting.CatalogExportProvider.GetExportedValue(CatalogPart part, ExportDefinition export, Boolean isSharedPart)
       at System.ComponentModel.Composition.Hosting.CatalogExportProvider.CatalogExport.GetExportedValueCore()
       at System.ComponentModel.Composition.Primitives.Export.get_Value()
       at System.ComponentModel.Composition.ExportServices.GetCastedExportedValue[T](Export export)
       at System.ComponentModel.Composition.Hosting.ExportProvider.GetExportedValueCore[T](String contractName, ImportCardinality cardinality)
       at System.ComponentModel.Composition.Hosting.ExportProvider.GetExportedValueOrDefault[T](String contractName)
       at System.ComponentModel.Composition.Hosting.ExportProvider.GetExportedValueOrDefault[T]()
       at Microsoft.VisualStudio.Activities.WorkflowDesignerExtensionManager.InternalGetExtension[T]()
    -------------------------

    In the warning log I have many messages: 

    Severity Code Description Project File Line Suppression State
    Warning Cannot initialize the following SharePoint project item: 'CustomWorkflowAction'. This item requires a type provider that has the following ID, but this provider could not be found: 'Microsoft.VisualStudio.SharePoint.Workflow4CustomActivity'. Reinstall the extension that provides this item type, or remove the item from your project. TestWFActions 0


    • Edited by Roman Rylov Thursday, April 21, 2016 8:57 AM
    Wednesday, April 20, 2016 9:53 PM

All replies

  • Hi Roman Rylov,

    Please create a default SharePoint project with with custom workflow actions and reopen it to check whether the new project also has this issue.

    If the new project also has this issue, this problem is more related to Visual Studio and computer environment.

    Please try reset/repair your Visual Studio to check whether this problem can be fixed. And if possible, please try open this project on another computer which also installed the same version of Visual Studio.

    If the new project is works fine, this problem should be related to the project itself. According to the error message, it should miss a provider which can't be found. Please contact this project creator to confirm which extension is missing.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Friday, April 22, 2016 7:36 AM
    Moderator
  • Weiwei Cai

    I have tried to create a new project the issue repeats. 

    Also, I tried to run Visual Studio installer in "repair" mode, but it doesn't help. The same project opens fine on another computer. 

    Thursday, April 28, 2016 12:29 PM
  • Hi Roman Rylov,

    Since this problem just occurs on one current Visual Studio, please try with following steps to troubleshoot this problem.

    1. Run your Visual Studio as administrator to make sure your Visual Studio has enough permissions to get all dlls on your machine.
    2. Run Visual Studio in safe mode to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Close all third part software when running Visual Studio, such as antivirus。
    4. Please use http://aka.ms/vscollect  to gather the VS and .Net Frameowrk installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to Onedrive and share the link here.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Friday, April 29, 2016 2:58 AM
    Moderator
  • Weiwei, 

    Please find the log file here 

    https://onedrive.live.com/redir?resid=DDFD985F34BB743D!1380&authkey=!ABJv2uyByT9mUDA&ithint=file%2czip

    Thursday, May 5, 2016 10:26 PM
  • Hi Roman Rylov,

    I don't find any installation error in your installation log and the exit code is 0x0, which means your Visual Studio installed correctly.

    What's the result about run Visual Studio as administrator and in safe mode?

    According to the warning message in your original post, this problem seems related to the 'Microsoft.VisualStudio.SharePoint.Workflow4CustomActivity' extension. Please try uninstall and reinstall this extensions for your Visual Studio to check whether the problem can be fixed.


    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, May 6, 2016 5:32 AM
    Moderator
  • Weiwei

    >>What's the result about run Visual Studio as administrator and in safe mode?

    I tried the with the same result. 

    >>According to the warning message in your original post, this problem seems related to the 'Microsoft.VisualStudio.SharePoint.Workflow4CustomActivity' extension. Please try uninstall and reinstall this extensions for your Visual Studio to check whether the problem can be fixed

    Thanks for the answer, could you please clarify how to reinstall the extension? 



    Friday, May 6, 2016 10:05 AM
  • Hi Roman Rylov,

    I'm don't familiar with SharePoint project, I don't confirm which extension will use the Workflow4CustomActivity. Please try with following steps to troubleshoot this problem.

    1. Please open your current Visual Studio and another Visual Studio which can open your project correctly.
    2. Open both of Tools menu -> Updates and Extensions in Visual Studio to compare whether there has any Updates different in each of Visual Studio.
    3. If all installed extensions are the same, please reinstall these extensions which related to SharePoint one by one to confirm which one causes this problem.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, May 9, 2016 9:36 AM
    Moderator