none
MS SQL Management studio 18 not starting

    Question

  • I have installed latest SMSS (Downloaded May 5th, 2019). It worked for 3 days, and then when I try to start it, it just closed with windows sound error, but no message on any of my screens. 

    I have reinstalled SMSS (from same installation file), and it started working again for a couple of days, but then, same thing happen.

    Application can not be seen in task manager.

    Any advice? What is happening?

    Tuesday, May 14, 2019 7:09 AM

Answers

  • Hey,

    I was having the same issue. The splash screen would appear and the just closes with the error chime. No error message or anything of the sort.

    Restarted my PC, issue still persisted. I then remembered that it worked for me two days ago and that I also updated windows as well 2 days ago.

    Uninstalling the following windows patch fixed it for me: KB4499167

    Regards,

    Edward

    Saturday, May 18, 2019 7:45 AM

All replies

  • Hi,

    Please try to update to the latest version of .NET framework. You can download it from here.

    If it doesn't work, you can try to use SSMS 17.9.1. You can download it from Release notes for SQL Server Management Studio (SSMS).

    Best Regards,
    Puzzle
    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, May 15, 2019 1:35 AM
  • Hey,

    I was having the same issue. The splash screen would appear and the just closes with the error chime. No error message or anything of the sort.

    Restarted my PC, issue still persisted. I then remembered that it worked for me two days ago and that I also updated windows as well 2 days ago.

    Uninstalling the following windows patch fixed it for me: KB4499167

    Regards,

    Edward

    Saturday, May 18, 2019 7:45 AM
  • Copy the File : Microsoft.VisualStudio.Shell.Interop.8.0.dll
    Located in
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PrivateAssemblies\Interop

    Paste in the Folder
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PublicAssemblies

    Everything will be fine 

    • Proposed as answer by TorMH Tuesday, May 21, 2019 7:38 AM
    • Unproposed as answer by TorMH Tuesday, May 21, 2019 7:38 AM
    • Proposed as answer by TorMH Tuesday, May 21, 2019 7:38 AM
    Monday, May 20, 2019 1:37 AM
  • Have the exact same issue ... Splash screen shows for a second, it dissapears and nothing happens. No entries in event log either.
    Monday, May 20, 2019 10:53 AM
  • Copy the File : Microsoft.VisualStudio.Shell.Interop.8.0.dll
    Located in
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PrivateAssemblies\Interop

    Paste in the Folder
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PublicAssemblies

    Everything will be fine 

    Confirmed, this works ...
    Monday, May 20, 2019 10:55 AM
  • Have the exact same issue ... Splash screen shows for a second, it dissapears and nothing happens. No entries in event log either.

    I found a solution:

    Copy the File : Microsoft.VisualStudio.Shell.Interop.8.0.dll
    Located in
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PrivateAssemblies\Interop

    Paste in the Folder:
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\

    It was already in the folder:
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PublicAssemblies\

    It was another forum, where they argue for GAC registration, that led me to the solution.

    So this little change worked for me
    Monday, May 20, 2019 11:29 AM
  • thanks it work for me
    Wednesday, May 22, 2019 3:24 AM
  • Wow, confirmed this works. Please fix this up Microsoft!
    Wednesday, May 22, 2019 1:48 PM
  • Thank you!!! it worked
    Wednesday, May 22, 2019 1:48 PM
  • Thank you, TomKK2019, your solution worked for me as well on a clean install of Windows 10, with SSMS 18.0.
    Wednesday, May 22, 2019 2:16 PM
  • Thanks - your advice works.
    Thursday, May 23, 2019 7:36 AM
  • This worked for me... The file was already in Public Assemblies, but copying to the IDE folder was the trick
    Thursday, May 23, 2019 4:36 PM
  • Thank you.  Now I can help everyone else again!
    Thursday, May 23, 2019 11:46 PM
  • Worked for me as well :)
    Friday, May 24, 2019 8:10 AM
  • Confirm... This work...

    TY


    Luís Ferreira

    Friday, May 24, 2019 1:31 PM
  • This worked for me! Thanks
    Friday, May 24, 2019 1:33 PM
  • Copy the File : Microsoft.VisualStudio.Shell.Interop.8.0.dll
    Located in
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PrivateAssemblies\Interop

    Paste in the Folder
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PublicAssemblies

    Everything will be fine 

    You are a legend! Thank you.
    Friday, May 24, 2019 2:39 PM
  • Thank you very Much,

    Its work for me and resolved my problem

    Very great

    Once again Thanks

    Ketan Rajput

    Monday, May 27, 2019 6:11 AM
  • Worked for me also ! Thanks !!!!
    Monday, May 27, 2019 6:45 AM
  • Thanks a lot
    Monday, May 27, 2019 5:19 PM
  • Worked for me as well. Agree that MS should fix this in their installation. 
    Wednesday, May 29, 2019 8:21 AM
  • It really works!
    Wednesday, May 29, 2019 2:14 PM
  • Confirmed, this works.
    Wednesday, May 29, 2019 4:49 PM
  • Thank you .Now life is good
    Thursday, May 30, 2019 6:42 AM
  • worked on my server. thanks.
    Thursday, May 30, 2019 5:42 PM
  • My problem it was resolved, thaks for help us.
    Sunday, June 2, 2019 10:50 PM
  • Have the exact same issue ... Splash screen shows for a second, it dissapears and nothing happens. No entries in event log either.

    I found a solution:

    Copy the File : Microsoft.VisualStudio.Shell.Interop.8.0.dll
    Located in
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PrivateAssemblies\Interop

    Paste in the Folder:
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\

    It was already in the folder:
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PublicAssemblies\

    It was another forum, where they argue for GAC registration, that led me to the solution.

    So this little change worked for me

    Thanks this step fixed it for me too!


    Pratap Ladhani

    Tuesday, June 4, 2019 3:24 AM
  • Magical!!! it worked for me. 
    Wednesday, June 5, 2019 8:47 PM
  • Thank you. This worked.
    Wednesday, June 12, 2019 11:42 AM
  • Worked like a charm, thank you! 
    Wednesday, June 12, 2019 3:28 PM
  • Please change your accepted answer, the answer below posted by Asim Abdalla Jaafar is the more pertinent solution as it does not require rolling back windows updates:


    Solution:

    COPY Microsoft.VisualStudio.Shell.Interop.8.0.dll
    Located in
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PrivateAssemblies\Interop

    Paste in the Folder
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PublicAssemblies

    Replace file in destination.

    Wednesday, June 12, 2019 3:33 PM
  • The copy paste solution worked for me too! Thank you!
    • Edited by NovixNS Thursday, June 13, 2019 11:12 AM
    Thursday, June 13, 2019 11:11 AM
  • Thank you very mach, it works for me too :) 
    Monday, June 17, 2019 1:17 PM
  • Copy the File : Microsoft.VisualStudio.Shell.Interop.8.0.dll
    Located in
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PrivateAssemblies\Interop

    Paste in the Folder
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PublicAssemblies

    Everything will be fine 

    Confirmed! This solution works without too much grammar

    Chief007

    Tuesday, June 18, 2019 8:58 AM
  • None of the solutions in this post worked for me:
    1) Neither Copying the File : Microsoft.VisualStudio.Shell.Interop.8.0.dll
    2) Nor registering with "C:\Program Files (x86)\Microsoft SDKs\Windows\v10.0A\bin\NETFX 4.7.2 Tools\gacutil"
    3) Not even repairing the installation by re-installing SSMS 18 (GA)

    My only hope is downloading the latest SSMS 18.1, the Release notes of which says:

    "SSMS setup - Fixed an issue where SSMS was exiting immediately after showing the splash screen. 
    See these sites for more details: feedback forum, SSMS Refuses to Start, and Database Administrators."

    https://feedback.azure.com/forums/908035/suggestions/37502512
    https://dba.stackexchange.com/questions/238609/ssms-refuses-to-start

    Will let you know...

    20 hours 24 minutes ago
  • Yep that the fix: The installation of SSMS 18.1 repairs SSMS 18(GA) & does not require a reboot/restart
    ~~~~~~~~~~
    https://docs.microsoft.com/en-gb/sql/ssms/download-sql-server-management-studio-ssms?view=sql-server-2017

    19 hours 58 minutes ago