none
Manifest Registry Entry in VS Setup Project Needs file:/// at the beginning RRS feed

  • General discussion

  • I wanted to share this with the group as it was causing me some issues.

    I checked out all the MSDN articles on creating a setup project for my Project 2010 addin. They covered the need to add my own registry entries. One of them is the 'Manifest' entry which needs to point to the location and file name for your .vsto file for your addin. According to this page my entry in my setup needed to look like this: "[TARGETDIR]ADDINNAME.vsto|vstolocal".

    I did this and my addin installed and my ribbon tab and buttons were all there and a few of my tools worked correctly but there were some oddities, including the inability for my application to read from my application settings and the failure (no errors, just nothing happening) of some load and button click events. After speaking to a friend with a ton more experience than i do on these subjects I added 'file:///' to the beginning of my entry so that it looked like this "file:///[TARGETDIR]ADDINNAME.vsto|vstolocal" and now everything works great.

    Im not suggesting that this will work for everyone but it worked for me. I hope this post might save some others from wasting as much time as I did on this. :-)


    Brian Kennemer – DeltaBahn Senior Architect
    endlessly obsessing about Project Server…so that you don’t have to.
    Blog | Twitter | LinkedIn
    Wednesday, January 11, 2012 9:56 PM

All replies

  • Hi Brian,

    Thanks for sharing your solution with us. Actually, I have tested what you said, changing the "[TARGETDIR]AddinName.vsto|vstolocal" to "file:///[TARGETDIR]AddinName.vsto|vstolocal", and both entries work for my Excel, Word, Powerpoint VSTO solutions. I'll tell you later what's the result for my Project VSTO solution.

    Good day;)


    Calvin Gao[MSFT]
    MSDN Community Support | Feedback to us


    Monday, January 16, 2012 5:45 AM
    Moderator