locked
Page editor options bug? RRS feed

  • Question

  • I have an annoying issue with Expression Web 4 (sp2).

    I'm trying to disable the "automatically switch keyboard to match language of surrounding text" setting in page editor options, but seems that the value of this setting isn't saved when app closes. Everytime expression web restarts, this specific setting reverts to enabled.

    Any idea?


    Thursday, July 28, 2011 11:19 PM

Answers

  • I think I've found what's wrong. Seems definitely an EW4 bug.

    When EW4 runs for very first time it creates in registry the following two REG_DWORD key values.

    HKCU\Software\Microsoft\Expression\Web\4.0\Legacy\12.0\Common\LanguageResources\InstallLanguage=xxx

    HKCU\Software\Microsoft\Expression\Web\4.0\Legacy\12.0\Common\LanguageResources\PreviousInstallLanguage=xxx

    ...with xxx being the EW installation language code (0x00000408(1033) for English). When running for first time on a non-English locale OS, even though EW installer and application are still English, those two values are created equal to the locale language code instead (0x00000409(1032) for Greek in my case).

    And here comes the possible bug. When those two values are different from the application language ID, the keyboard switching option state for some unknown reason is not stored in registry, and always reverts to enabled. After I manually changed the above two registry keys to English ID (0x00000408(1033)), the keyboard switching setting works as it should, saving its state between sessions.

    Now I have to overcome my poor English and fill out a bug report. Maybe some of the MSFT folks could help me with this? :o)


    • Proposed as answer by PanGT Friday, July 29, 2011 5:33 PM
    • Marked as answer by AthanD Friday, July 29, 2011 5:46 PM
    • Edited by AthanD Tuesday, August 9, 2011 1:46 PM
    Friday, July 29, 2011 5:04 PM

All replies

  • All I can say is I have no problem.  It's off, and it stays off, for me.
    Thursday, July 28, 2011 11:45 PM
  • Thanks for answering, Kathy.

    That's really weird! I tried countless times setting it to off but it always reverts to "enabled" when EW4 restarts.

    I tried resetting settings, removing the whole EW4 registry tree, reinstalling EW4 from scratch on a second system but it always behave the same. All settings are saved just fine, except this one.

    Do you have a second keyboard layout configured in Windows regional settings? This setting has no meaning with a single keyboard layout configured, thus it might behave differently.





    Thursday, July 28, 2011 11:56 PM
  • The checkbox on mine is unchecked.


    Nancy Ward
    Friday, July 29, 2011 2:54 AM
  • Like the others I can't replicate but I've noticed that sometimes when people have their sites in c:/users/account/my documents/my websites that sometimes options are "locked". I don't keep my sites in my user account because I have too many and some of them are very large. I don't need the overhead in loading and by keeping them on my d drive they are easier to back-up (that's been my practice for over 15 years).

    Anyway, if your sites are located in your profile create anew site either on another drive or in a folder straight on your c drive such as c:/webs/newsite then see if you can change the settings in Tools > Page Editor Options while in that web.


    Free Expression Web Tutorials
    For an Expression Web forum with without the posting issues try expressionwebforum.com
    Friday, July 29, 2011 4:09 AM
  • It didn't help either, Cheryl.

    This checkbox remains checked after EW4 restarts. No problem with other settings though.

    Don't know what else to try. 


    Friday, July 29, 2011 10:16 AM
  • I wonder if it has anything to do with your system language settings. Is your keyboard setting the same as the main language setting?
    Ian Haynes

    EW V4 Add-Ins
    EW resources, hints and tips
    Friday, July 29, 2011 10:49 AM
  • Thanks for trying to help, Ian!

    As installed by default, I have two keyboard layouts in regional settings; English (US) and Greek with English being the default one. System is Windows 7 Pro x64 (Intl English version).

    The problem with "autoswitch keyboard" setting not being saved occurs with either keyboard language. And btw I could understand If it was just a keyboard switching glitch; but not saving an option state?

    Friday, July 29, 2011 11:10 AM
  • Thanks for trying to help, Ian!

    As installed by default, I have two keyboard layouts in regional settings; English (US) and Greek with English being the default one. System is Windows 7 Pro x64 (Intl English version).

    The problem with "autoswitch keyboard" setting not being saved occurs with either keyboard language. And btw I could understand If it was just a keyboard switching glitch; but not saving an option state?


    Shouldn't be necessary, but.... try setting it with a site open?
    Expression Web MVP
    Friday, July 29, 2011 1:04 PM
  • Already did that, Steve. Still the same.

    Even tried a fresh install of EW4 first with no service packs at'all and then with only SP1. A clean installation of both Windows 7 Pro + EW4 (with and w/o SP1,2) didn't help either.

    I've put aside my Expression Web DVD and downloaded the trial version to give it a try too; same results. The only thing I haven't try yet is to install EW4 on 32bit system. Unfortunately I only have 64bit OS images here. EW4 under Windows 7 XP mode (32bit) behaves exactly the same, though.

    I really don't know what to think anymore. I've run out of ideas. Why this damn setting is being saved in all your setups but not mine?

    Maybe it's time for an ...exorcism. :o)

    Friday, July 29, 2011 1:33 PM
  • I think I've found what's wrong. Seems definitely an EW4 bug.

    When EW4 runs for very first time it creates in registry the following two REG_DWORD key values.

    HKCU\Software\Microsoft\Expression\Web\4.0\Legacy\12.0\Common\LanguageResources\InstallLanguage=xxx

    HKCU\Software\Microsoft\Expression\Web\4.0\Legacy\12.0\Common\LanguageResources\PreviousInstallLanguage=xxx

    ...with xxx being the EW installation language code (0x00000408(1033) for English). When running for first time on a non-English locale OS, even though EW installer and application are still English, those two values are created equal to the locale language code instead (0x00000409(1032) for Greek in my case).

    And here comes the possible bug. When those two values are different from the application language ID, the keyboard switching option state for some unknown reason is not stored in registry, and always reverts to enabled. After I manually changed the above two registry keys to English ID (0x00000408(1033)), the keyboard switching setting works as it should, saving its state between sessions.

    Now I have to overcome my poor English and fill out a bug report. Maybe some of the MSFT folks could help me with this? :o)


    • Proposed as answer by PanGT Friday, July 29, 2011 5:33 PM
    • Marked as answer by AthanD Friday, July 29, 2011 5:46 PM
    • Edited by AthanD Tuesday, August 9, 2011 1:46 PM
    Friday, July 29, 2011 5:04 PM
  • Actually, I don't think you need any help. You've pretty much summarized what you have found right there in that post, and how they can reproduce it. Add an opening paragraph to it to describe the problem you're seeing (your first post to this thread would do nicely), and you've got your bug report.

    BTW, your English is just fine. Compared to my Greek, in fact, it pretty much kicks butt.  ;-)

    cheers,
    scott 


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    Friday, July 29, 2011 5:29 PM
  • I'll do that, Scott.

    Thanks for encouraging me with my English. ;)

    Friday, July 29, 2011 5:44 PM
  • I'd have never known that English wasn't your native language so consider your English to be excellent.


    Free Expression Web Tutorials
    For an Expression Web forum with without the posting issues try expressionwebforum.com
    Friday, July 29, 2011 6:43 PM
  • Thanks Cheryl; my English used to be much better when I was young but are getting rusty nowadays.
    Friday, July 29, 2011 7:42 PM
  • Understand, my French used to be very good, now it's marginal.
    Free Expression Web Tutorials
    For an Expression Web forum with without the posting issues try expressionwebforum.com
    Friday, July 29, 2011 8:40 PM