locked
wcf data services Problems RRS feed

  • Question

  • http://msdn.microsoft.com/en-us/library/dd728279.aspx

    shows 

    This XML file does not appear to have any style information associated with it. The document tree is shown below.    

    <service xml:base="http://localhost:12345/Northwind.svc/"><workspace><atom:title>Default</atom:title><collection href="Customers"><atom:title>Customers</atom:title></collection><collection href="Order_Details"><atom:title>Order_Details</atom:title></collection><collection href="Orders"><atom:title>Orders</atom:title></collection></workspace></service>

    http://localhost:12345/Northwind.svc/Customers

    after  this given link to browser it shows 

    Customers

          Saturday, May 18, 2013 ( 91 Times)

    it wont show any data base tables values

    • Moved by Haixia_Xie Tuesday, May 21, 2013 3:06 AM wcf data services issue
    Monday, May 20, 2013 1:09 PM

Answers

  • In the MSDN link you posted above there's this:

    In Internet Explorer, from the Tools menu, select Internet Options, click the Content tab, click Settings, and clear Turn on feed viewing.

    This makes sure that feed reading is disabled. If you do not disable this functionality, then the Web browser will treat the returned AtomPub encoded document as an XML feed instead of displaying the raw XML data.

    Please turn off the feed viewing (you may need to close the browser for the change to take effect) and try again.

    Thanks,


    Vitek Karas [MSFT]

    • Marked as answer by srk boss Wednesday, May 22, 2013 6:23 AM
    Tuesday, May 21, 2013 4:24 PM
    Moderator

All replies

  • In the MSDN link you posted above there's this:

    In Internet Explorer, from the Tools menu, select Internet Options, click the Content tab, click Settings, and clear Turn on feed viewing.

    This makes sure that feed reading is disabled. If you do not disable this functionality, then the Web browser will treat the returned AtomPub encoded document as an XML feed instead of displaying the raw XML data.

    Please turn off the feed viewing (you may need to close the browser for the change to take effect) and try again.

    Thanks,


    Vitek Karas [MSFT]

    • Marked as answer by srk boss Wednesday, May 22, 2013 6:23 AM
    Tuesday, May 21, 2013 4:24 PM
    Moderator
  • It works for me.I un check the turn on feed reading view which is in

    'Tools->Internet Option->content->Feeds And Web Slices->Settings ' helps me.

    Thanks.

    ----------------------

    srk Boss

    Wednesday, May 22, 2013 6:36 AM