locked
Microsoft Help Viewer 1.0 cannot update documentation due to proxy authentication errors

    Question

  • After running into this error on the final released version of Visual Studio 2010, I decided to take matters into my own hands. I modified the application config file of the help manager (C:\Program Files\Microsoft Help Viewer\v1.0\HelpLibManager.exe.config on my machine) and the "HelpLibAgent.exe.config" and added this section to both files:

      <system.net>
        <defaultProxy useDefaultCredentials="true">
        </defaultProxy>
      </system.net>

    This lets me see that there are updates and new content available. When I attempt to update, I now get a new exception being caught. I'll include the details from it at the end.

    The issue is that we do operate behind a firewall and a proxy that requires authentication. I don't have the ability to modify this. The permissions are set automatically through group policy. I also don't have a problem attempting to get to the web pages manually using Internet Explorer 8. I've attempted to run the help manager utility using elevated privileges on Windows Vista Business 32 bit OS. I've never really had luck with .net apps automatically picking up the proxy configuration from IE.

    Any pointers on what to try next?

    An error occurred while updating local content: Microsoft.Help.CacheLib.CacheLibDownloadException: An error occurred while the BITS service was transferring 'http://packages.mtps.microsoft.com/brands/dev10.cab' to 'C:\ProgramData\Microsoft\HelpLibrary\content\Microsoft\incoming\cee4b060-a0c2-4aa6-98cf-58dbebf12d00\dev10.cab'. The error context was 'RemoteFile', and the error code was '0x80190197'.
      at Microsoft.Help.CacheLib.DocumentationCache.<>c__DisplayClass6c.<DownloadWebContent>b__69(IGrouping`2 chunk)
      at Microsoft.Help.CacheLib.Extensions.Each[T](IEnumerable`1 that, Action`1 lambda)
      at Microsoft.Help.CacheLib.DocumentationCache.DownloadWebContent(IEnumerable`1 webDownloads, Int32 totalDownloads, Int32 completedDownloads, String workingDirectory, StatusCallback`1 statusCallback)
      at Microsoft.Help.CacheLib.DocumentationCache.Download(ChangeDescription change, StatusCallback`1 statusCallback)
      at Microsoft.Help.CacheLib.DocumentationCache.Update(VendorName vendorName, Boolean checkForOnlineUpdates, StatusCallback`1 statusCallback, CertificateCheckCallback certCheckCallback)
      at Microsoft.Help.CacheLib.CacheManager.<>c__DisplayClass24.<UpdateAsync>b__23()
      at Microsoft.Help.CacheLib.AsyncOperationRunner.Run(Object state)

     

    Monday, April 26, 2010 2:47 PM

Answers

  • I was having the exact same problem, and found this post trying to fix it.

    The second half of the problem is with BITS, and not the help system.  http://support.microsoft.com/kb/842309

    To work around this problem by changing the method that the BITS 2.0 client uses to provide logon credentials to the server, create a UseLmCompat registry value in the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\BITS subkey, and then add a DWORD value of 0. To do this, follow these steps on the BITS 2.0 client computer:
    1. Click Start, click Run, and then type regedit.
    2. Locate the following subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\BITS
    3. Right-click BITS, point to New, click DWORD Value, type UseLmCompat, and then press ENTER.
    4. In the right pane, right-click UseLmCompat, and then click Modify.
    5. In the Value data box, type 0, and then click OK.
    6. Quit Registry Editor.
    7. Restart the BITS 2.0 service.

     

    • Marked as answer by MartinJ Tuesday, April 27, 2010 4:30 PM
    Tuesday, April 27, 2010 4:25 PM

All replies

  • Hi Martin

    You can add a proxy server to it:

            <defaultProxy enabled="true" useDefaultCredentials="true">
                <proxy bypassonlocal="True" proxyaddress="http://yourproxy"/>
            </defaultProxy>

    Otherwise, you may contact your IT admin for the problem.

    Thanks.


    Figo Fei
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com 


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, April 27, 2010 7:29 AM
  • After I added the proxy information, I still get the same error message. It's been my experience developing internal .net applications that I only needed to add the hint to use the default credentials to get through the proxy. The proxy address is being automatically collected.

    Our network is using Windows Server Update Service. I am able, though, to have Windows Update bypass the internal server (after they gave local administrators back the right to actually do this). Somehow, I doubt that we will be able to resolve this. There may be too many adjustments that our agency will be unwilling to loosen. If it might be possible to bypass BITS and interactively download content updates, that would be great.

    Tuesday, April 27, 2010 12:35 PM
  • I was having the exact same problem, and found this post trying to fix it.

    The second half of the problem is with BITS, and not the help system.  http://support.microsoft.com/kb/842309

    To work around this problem by changing the method that the BITS 2.0 client uses to provide logon credentials to the server, create a UseLmCompat registry value in the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\BITS subkey, and then add a DWORD value of 0. To do this, follow these steps on the BITS 2.0 client computer:
    1. Click Start, click Run, and then type regedit.
    2. Locate the following subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\BITS
    3. Right-click BITS, point to New, click DWORD Value, type UseLmCompat, and then press ENTER.
    4. In the right pane, right-click UseLmCompat, and then click Modify.
    5. In the Value data box, type 0, and then click OK.
    6. Quit Registry Editor.
    7. Restart the BITS 2.0 service.

     

    • Marked as answer by MartinJ Tuesday, April 27, 2010 4:30 PM
    Tuesday, April 27, 2010 4:25 PM
  • That looks like it did the trick. Thanks.
    Tuesday, April 27, 2010 4:31 PM
  • This worked. Thank you.

    Tuesday, September 20, 2011 10:40 PM