locked
Windows Azure Tools: Failed to initialize Windows Azure storage emulator. Unable to start Development Storage. Port conflict with existing application RRS feed

  • Question

  • Hi All,

     I am teaching Windows Azure, and i made terminal server where each student can login and use Azure (VS2010 + Sdk 1.8 )

    When two or more students are starting the AZURE application i get this alert :

    "Windows Azure Tools: Failed to initialize Windows Azure storage emulator. Unable to start Development Storage. Port conflict with existing application."

    This is probably because everyone use the same port , no ?
    Who can i solve this conflict? can i use different storage port for each student ?
    Thanks,
    Erez
    Tuesday, June 25, 2013 9:23 AM

Answers

All replies

  • These are the few options, I can suggest.

    1. If you are not going to do any Storage operations, then remove default Storage Emulator initialization on run/debug of your solution in VisualStudio. Go to Cloud Project Properties > Development > Start Windows Azure Storage Emulator > False.

    2. This may work, need to try. Instead of http://127.0.0.1:10000, for development storage URIs, you can specify a proxy URI, like 

    You can also specify an HTTP proxy to use when you're testing your service against the storage emulator. This can be useful for observing HTTP requests and responses while you're debugging operations against the storage services. To specify a proxy, add the DevelopmentStorageProxyUri option to the connection string, and set its value to the proxy URI. For example, here is a connection string that points to the storage emulator and configures an HTTP proxy:
    UseDevelopmentStorage=true;DevelopmentStorageProxyUri=http://myProxyUri

    Because, I don't know whether we can change the port. So, at least URI proxy can be used.

    3. If everything failed to work, you can start having a separate VM for each student to have their own environment with out any such mess up of common resources.

    Hope this helps you...


    Mahesh Jasti

    • Proposed as answer by Jasti Mahesh Tuesday, June 25, 2013 1:04 PM
    Tuesday, June 25, 2013 1:04 PM
  • Thanks!

    I will try.

    Unfrotunatly, in this point of the semester i cant do the VM .

    Erez

    Tuesday, June 25, 2013 3:02 PM
  • HI.

    I tryed No.1 and get

    "Windows Azure Tools: Access is denied."

    No2 doesnot work cause probably it uses the same emultor.

    Can you tell if you familiar with No1 error /?

     

    Tuesday, June 25, 2013 5:43 PM
  • I tried it as shown in below pic and it works with out any errors...

    I even tried like, 1. created another user accout on my machine and 2. Tried to reproduce your error message by following my suggestion#1 using the other user account.

    It is working fine... at my end.

    It would be helpful, if you can give more details.

    Check - http://stackoverflow.com/questions/12749501/visual-studio-cant-start-azure-debugging-environment


    Mahesh Jasti

    Wednesday, June 26, 2013 4:37 AM
  • Hi,

    You may also have a look at these two links about hosting storage emulator for local network:

    http://webcache.googleusercontent.com/search?q=cache:Gb1bZF_NrXMJ:www.infosysblogs.com/microsoft/2011/03/configuring_azure_development.html+Configuring+Azure+development+storage+for+team+development+scenarios&cd=1&hl=en&ct=clnk

    http://blog.piyushthacker.com/?p=24

    Thanks,


    QinDian Tang
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, June 26, 2013 5:47 AM