locked
Cannot update Xamarin.Forms from 3.4.0.1029999 to 3.5.0.169047 RRS feed

  • Question

  • User188068 posted

    I have a Xamarin.Forms solution with .netStandard 2.0 core project projectname. It stops compiling immediately after I try to upgrade Xamarin.Forms from 3.4.0.1029999 to 3.5.0.169047. It complains to every single .xaml file with the same error: "filename.xaml: [null] Failed to resolve assembly: 'projectname_, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'". The problem repeats in Rider, VS for Mac and on CI. I also tried updating to the nearest 3.5.0.62956-pre2 and latest 4.0.0.169046-pre5 pre-release versions with no luck.

    As long as a new project updates seamlessly, I assume there is some issue specific to my project, but I have no clue where to look for it.

    Friday, February 22, 2019 12:16 PM

All replies

  • User102046 posted

    @anna.domashych have you tried it with stable XF releases?

    Friday, February 22, 2019 12:56 PM
  • User188068 posted

    That's what I have started from, Xamarin.Forms 3.5.0.169047

    Friday, February 22, 2019 12:59 PM
  • User188068 posted

    I have managed to identify the problem. Some of the models in my project are marked with [Equals] attribute, and Equals.Fody 1.9.4 is referenced. I all works fine until the model has a nullable enum property. That's when the project stops building.

    Friday, February 22, 2019 3:02 PM