none
microsoft.ace.oledb.12.0' provider is not registered on the local machine RRS feed

  • Question

  • I using Windows 8 (64bits)

    Microsoft Office 2007 (32bits)

    SQL Server 2012 (32bits)

    I need to create a function in VB to export the data from SQL server to a excel file. But i get the error 

    microsoft.ace.oledb.12.0' provider is not registered on the local machine

    My connection String is as below

    "Provider=Microsoft.ACE.OLEDB.12.0;" & _
     "Data Source=" & lsTargetDir & ";" & _
     "Extended Properties=""Excel 12.0;HDR=YES"""


    Thursday, August 1, 2013 3:31 AM

Answers

  • If the version of Office installed is 32-bit then you need to make certain the Platform option (Build...Configuration Manager...) in your project is set to x86 so that your app runs 32-bit in 64-bit Windows (and uses the 32-bit OLEDB Provider).

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Thursday, August 1, 2013 11:39 AM
  • Hello microsoft.ace.oledb.12.0' issue,

    Welcome toMSDN Support Forum.

    I am agreed with Paul P Clement IV.

    From your description,I notice that your PC environment is 64-bit and your office is 32-bit.

    So you can check what platform your solution will be built to be.Like following:

    Change it to X86 so that your solution will be built to 32-bit.

    I look forward to hearing from you.

    Best Regards


    Fred Bao
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, August 2, 2013 1:49 AM
    Moderator

All replies

  • If the version of Office installed is 32-bit then you need to make certain the Platform option (Build...Configuration Manager...) in your project is set to x86 so that your app runs 32-bit in 64-bit Windows (and uses the 32-bit OLEDB Provider).

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Thursday, August 1, 2013 11:39 AM
  • Hello microsoft.ace.oledb.12.0' issue,

    Welcome toMSDN Support Forum.

    I am agreed with Paul P Clement IV.

    From your description,I notice that your PC environment is 64-bit and your office is 32-bit.

    So you can check what platform your solution will be built to be.Like following:

    Change it to X86 so that your solution will be built to 32-bit.

    I look forward to hearing from you.

    Best Regards


    Fred Bao
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, August 2, 2013 1:49 AM
    Moderator
  • i got same problem, and  my Visual Studio 2010 premium only has "Any CPU" platform.

    if i set run 32 bit application from IIS, my oracle stop working.

    Tuesday, August 20, 2013 7:43 AM
  • I am running Win 7 64 bit, visual basic express 10 and office 2007.  I get the same error (microsoft.ace.oledb.12.0' provider is not registered on the local machine) trying to write code to connect to Access 2007.  The error is attached to the connection.open method.  If I  go to the build window which in my version, the tab is labeled compile and looks quite different, the text box labeled platform only allows me to select: Active (Any CPU).  There is no other option.  What am I missing?

    Friday, August 23, 2013 4:14 AM
  • I am running Win 7 64 bit, visual basic express 10 and office 2007.  I get the same error (microsoft.ace.oledb.12.0' provider is not registered on the local machine) trying to write code to connect to Access 2007.  The error is attached to the connection.open method.  If I  go to the build window which in my version, the tab is labeled compile and looks quite different, the text box labeled platform only allows me to select: Active (Any CPU).  There is no other option.  What am I missing?

    I have the same problem. which you have mentioned here. I am using VS 2008, an access 2010, it has only one option "Any CPU" no other option. does anyone had the same problem and found solution for that?
    Monday, December 29, 2014 4:12 PM
  • I have the same problem. which you have mentioned here. I am using VS 2008, an access 2010, it has only one option "Any CPU" no other option. does anyone had the same problem and found solution for that?


    In the Platform dropdown (under Build...Configuration Manager...), click the <New...> item to add x86.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Monday, December 29, 2014 7:25 PM