locked
Visual Studio doesn't find Remote Machine? RRS feed

  • Question

  • Working with RPi2 kit and Visual Studio Community.  I can see the RPi2 on the IoT Dashboard and I can run the HelloBlinky example from the "Try Some Examples" page of the IoT Dashboard.  I set up for a "real" Blinky using a GPIO pin and breadboard LED.  Then I load the BlinkyCPP app into the Visual Studio.  Builds just fine.  However, the Remote Machine button is already set and clicking it just tries to load it on the host (a Surface II).  Complains that the code is for an ARM (no surprise there), but won't set up for the proper Remote Machine... so, the Deploy always fails.  Any ideas?
    Friday, February 12, 2016 3:12 PM

Answers

  • Have you set the correct address of your remote machine? You'll find the "Start options" by right-clicking your project in the Solution Explorer, select Properties and then the Debug-tab.

    Friday, February 12, 2016 3:18 PM
  • Dr. Hazelton, 

    I just opened the BlinkyCpp project, and I see what you mean.  Here is what I did to fix it when deploying to my Raspberry Pi 2:

    1. Change the platform from ARM back to x86
    2. Change the x86 debug target from "Local Machine" to "Remote Machine"
    3. Change the platform from x86 back to ARM
    4. Open your project properties
    5. Go to the Debug tab
    6. Set the "Machine Name" to the IP Address of your Pi
    7. Set the "Autehntication Type" to "Universal (Unencrypted Protocol)"

    Here's a link to a quick video showing how I fixed it: http://1drv.ms/1WhQSSL

    Hope that helps. 

    Bret

    Friday, February 12, 2016 5:14 PM

All replies

  • Have you set the correct address of your remote machine? You'll find the "Start options" by right-clicking your project in the Solution Explorer, select Properties and then the Debug-tab.

    Friday, February 12, 2016 3:18 PM
  • That works!  Not at all obvious from the kit instructions, and VERY well hidden from casual search.  That said, I seriously appreciate your assistance.  My little light is blinking!  Now, on to bigger things. :)
    Friday, February 12, 2016 4:56 PM
  • Dr. Hazelton, 

    I just opened the BlinkyCpp project, and I see what you mean.  Here is what I did to fix it when deploying to my Raspberry Pi 2:

    1. Change the platform from ARM back to x86
    2. Change the x86 debug target from "Local Machine" to "Remote Machine"
    3. Change the platform from x86 back to ARM
    4. Open your project properties
    5. Go to the Debug tab
    6. Set the "Machine Name" to the IP Address of your Pi
    7. Set the "Autehntication Type" to "Universal (Unencrypted Protocol)"

    Here's a link to a quick video showing how I fixed it: http://1drv.ms/1WhQSSL

    Hope that helps. 

    Bret

    Friday, February 12, 2016 5:14 PM