none
Azman not opening the authorization store, throws error “The parameter is incorrect” RRS feed

  • Question

  • I have a web server which is a windows Server 2008 R2 and is added to a domain. The problem is that when I open azman.msc and try to open the authorization store of type "Microsoft SQL" with a valid connection string which is in the format

    mssql://Driver={SQL Server};Server=MySQLInstanceName;Integrated Security=SSPI;/MyDataBaseName/MyAzManStore

    it gives an error

    Cannot open the authorization store. The following problem occurred: The parameter is incorrect.

    I am also getting the same error when I try to create a new authorization store. But when I do the same in app server(with the same connection string) which is in the same domain and configuration as webserver, it is able to open with out any error.

    Any possible way how to resolve this, my .net application uses azman to authorize users, which is not working because of this issue.

    PS: This was working fine before updating the machine with latest .NET Framework 4 and windows patches. Here are the list of .Net Framework and windows patches that are updated.

    .NET Framework 4
    KB2742595 - MS13-004
    KB2736428 - MS13-007
    KB2789642 - MS13-015 
    KB2737019 - MS12-074 
    KB2729449 - MS12-074
    KB2604121 - MS12-035
    KB2656351 - MS11-100 
    KB2487367 - MS11-066
    --
    Windows
    KB2840149 - MS13-036 
    KB2808735 - MS13-036
    KB2817183 - MS13-028
    KB2813347 - MS13-029 
    KB2813170 - MS13-031
    KB2719033 - MS12-073
    KB982666 - MS10-040 

    Wednesday, September 25, 2013 5:11 AM