locked
Sharepoint workflow appearing on the wrong library RRS feed

  • Question

  • Hello,

    I created a SharePoint workflow that should be executed when the user applies it to a document in Library 1 and which creates a copy of the document in Library 2. This workflow should only be used in the documents of Library 1. However, it appears as an option to apply to the documents in Library 2.

    Is there a way to avoid having the option of applying the workflow to the documents in Library 2? I know it appears on this library because this workflow uses Library 2 to create the copy, but I do not want to have the option of applying this workflow to the documents in Library 2.

    Any help would be appreciated.


    Friday, March 1, 2019 11:46 AM

All replies

  • Go to Library 2 and in the Ribbon click Work Flow Settings. Under the "Show Workflow Associations of this type:" pick the content type the library uses for the workflow task (the copy job you mentioned). Upon selection, you will see the workflow name in the Workflow Name section below. Click the name and Select Remove.

    This will remove the association and will not longer trigger should a user access the Library and add the specified item.

    Friday, March 1, 2019 4:34 PM
  • Hi

    Thanks for the reply.

    Which is the Ribbon where I can find Work Flow Settings?

    BTW, the workflow is not triggered if the user does not use it in Library 2, the problem is that Library 2 has the option to apply that workflow to its documents when it shouldn't.

    







    Friday, March 1, 2019 4:57 PM
  • Hi Rita, 

    If you just create this workflow in Library 1 to create a copy of the document in Library 2,  the workflow will not be applied in Library 2. 

    If you can see the workflow in Library 2, it seems that you create the workflow in Library 2. 

    To remove the workflow from Library 2, navigate to Library settings->Workflow Settings->Remove, Block, or Restore a Workflow, you can remove the workflow from Library 2. 

    Best Regards, 

    Lisa Chen 


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, March 4, 2019 9:09 AM
  • Thank you for your reply, Lisa.

    I tried doing that, however, when I go to the Workflow Settings it says that "There are no 2013 SharePoint Workflows associated with this list at this time." and the same for 2010 Workflows.

    Thursday, March 7, 2019 4:03 PM
  • Hi Rita, 

    You said that "However, it appears as an option to apply to the documents in Library 2." 

    What do you mean that it appears as an option to apply to the documents in Library 2? Please offer a screenshot about it. 

    Best Regards, 

    Lisa Chen 


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, March 8, 2019 9:40 AM
  • did you create this workflow as site workflow or content type workflow? If you want to have it only in one document library this workflow should be created as list workflow - and then you need to choose to which exact doclib you want to attach it (if you use Sharepoint Designer for creation workflow).

    Blog - http://sadomovalex.blogspot.com
    Dynamic CAML queries via C# - https://github.com/sadomovalex/camlex

    Friday, March 8, 2019 2:39 PM
  • @sadomovalex

    "did you create this workflow as site workflow or content type workflow?"

    I don't know. How can I figure that out?

    This is how I create flows:

    @Lisa Chen1226

    The flow 'Send Request for Approval' is supposed to be used on documents inserted in Library 1: Contractor Library Edit.

    Library 1

    The flow 'Send Request for Approval'  creates a copy of the file in Library 2: BET Library Edit-only.



    Library 2

    The issue here is that I do not wish to have the option to apply the flow 'Send Request for Approval' to the documents in Library 2: BET Library Read-only.




    • Edited by Rita Aguiar Wednesday, March 13, 2019 10:00 AM
    Wednesday, March 13, 2019 9:50 AM
  • Hi Rita, 

    You can create flow from the library  Library 1: Contractor Library Edit.

    Navigate to the  Library 1: Contractor Library Edit->Flow, create a flow, then the flow will not be displayed on the Library 2: BET Library Edit-only.


    Move a document from one SharePoint library to another using flow for your reference:

    https://melihubb.com/2018/04/08/move-a-document-from-one-sharepoint-library-to-another-using-flow/

    Best Regards, 

    Lisa Chen 


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.


    Tuesday, March 19, 2019 8:45 AM
  • Thank you Lisa Chen1226

    I will do that. Is there a way to copy another workflow on top of that workflow being created inside a library?
    I ask this because I have already spent a long time creating the flows and they are very complex. If I have to create them all again it will be very slow.

    • Edited by Rita Aguiar Tuesday, March 19, 2019 9:07 AM
    Tuesday, March 19, 2019 8:52 AM
  • Hi rita, 

    I am not familiar with flow. 

    I would suggest you can create a thread in flow forum, you will get more information from there and more experts there will help you.

    https://powerusers.microsoft.com/t5/General-Flow-Discussion/bd-p/FlowForum

    Thanks for your understanding.

    Best Regards, 

    Lisa Chen 


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, March 19, 2019 8:57 AM
  • Hi rita, 

    If a reply helps you, please remember to mark it as an answer, it will be beneficial to others in the community who meet this similar issue in the future. 

    Thanks for your understanding. 

    Best Regards, 

    Lisa Chen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, March 19, 2019 8:58 AM
  • Thank you once again Lisa Chen1226

    I have already posted this thread on there https://powerusers.microsoft.com/t5/Building-Flows/Sharepoint-workflow-appearing-on-the-wrong-library/m-p/252916#M25247.

    How do I create a new template without being obliged to the flow templates? These templates are apparently limiting myself on which options I can choose from. For example, I choose the second (ask for approval) and I couldn't selected the 'For a selected item' because it doesn't appear.



    Rita Aguiar



    • Edited by Rita Aguiar Tuesday, March 19, 2019 9:06 AM
    Tuesday, March 19, 2019 9:06 AM
  • Hi Lisa Chen1226
    A
    re you sure that by creating a flow directly from the Library page where it will be applied to the flow won't appear in other libraries? I recreated one of my flows again from scratch and from the library where this flow is meant to be triggered, but it still did not work and the flow is appearing in another library (the library where the item is copied to). 

    Rita Aguiar





    • Edited by Rita Aguiar Thursday, March 28, 2019 11:16 AM
    Monday, March 25, 2019 3:00 PM
  • Hi Rita, 

    I am not familiar with flow. 

    I would suggest you can create a new thread in flow forum, you will get more information from there and more experts there will help you.

    https://powerusers.microsoft.com/t5/General-Flow-Discussion/bd-p/FlowForum

    Thanks for your understanding.

    Best Regards, 

    Lisa Chen 


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, April 3, 2019 11:06 AM
  • Thank you Lisa Chen1226


    I have posted this question there already (https://powerusers.microsoft.com/t5/Building-Flows/Sharepoint-workflow-appearing-on-the-wrong-library/m-p/252916#M25247).

    Unfortunately no one has been able to help me there either.



    Rita Aguiar

    Wednesday, April 3, 2019 11:09 AM
  • Hi Rita, 

    You can try to create a new thread.

    Best Regards, 

    Lisa Chen 


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Thursday, April 4, 2019 11:06 AM