none
EVERY Report with Subreport failing since upgrade to 2015 Report Viewer RRS feed

  • Question

  • I have been working on an application for years, all was working fine under report viewer 10 libraries.  Due to upgrade requirements, I have hade to shift to using ReportViewer 2015 distribution.  My app running with C#.net 4.5 framework. All of my reports go through the same process and for brevity, my application has ALL my reports as Embedded Resources.  They all reside in their own respective sub-folder and all share common file naming convention.  In this example, I have

    \MyApp
    \MyApp\MyReport
    \MyApp\MyReport\RptMainData.rdlc
    \MyApp\MyReport\RptMainSubReport1.rdlc

    In my code, I am doing....

    var rv = new ReportViewer();
    rv.ProcessingMode = ProcessingMode.Local;

    var mainRptStream = Assembly.GetExecutingAssembly().GetManifestResourceStream( "MyApp.MyReport.RptMainData.rdlc" );
    var subRptStream = Assembly.GetExecutingAssembly().GetManifestResourceStream( "MyApp.MyReport.RptMainSubReport1.rdlc" );

    rv.LocalReport.LoadReportDefinition( mainRptStream );
    rv.LocalReport.LoadSubreportDefinition( "RptMainSubReport1", subRptStream );

    GoGetMyDataForReport(rv);

    // which then does
    // rv.LocalReport.DataSources.Add( myData ) which is of a 'ReportDataSource' type

    rv.SubreportProcessing += mySubReportHandler;
    rv.RefreshReport();

    // finally call my Window to display the report.

    Again, all else the same, only recently has it changed.  All the reports, sub reports, naming CamelCase consistency WAS working and now is not.  if I remove the subreport from the main report, it works.  I have even tried adding a new report with only a single column in it from the available data source and it still fails.

    I've searched for days and still not finding any working answers...

    Wednesday, August 7, 2019 2:58 AM