locked
Test agent not getting registered with the Test Controller RRS feed

  • Question

  • So here is the scenario

    I have two machines - a server machine on which lab manager is running ( the one with the test controller ) and a virtual machine for which i have installed the test agents

    But i am unable to register the test agent with the test controller

    I am getting an error saying that the user cannot may not have the appropriate permission..


    Tuesday, October 2, 2012 8:28 AM

Answers

All replies

  • Hi Nikhil Rajan,

    Make sure the user account you are using has the appropriate permissions to register the test agent to the test controller.

    In order to connect one test agent to one test controller, you need to add that user account to the TeamTestAgentService group on the computer that has the test controller installed.

    For further information see the Set Up Security for Test Controllers and Agents part of this MSDN article: http://msdn.microsoft.com/en-us/library/dd648127(VS.100).aspx#Security

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, October 3, 2012 4:51 AM
    Moderator
  • OK the user that i am using has the credentials - <VirtualMachine Name>\user, this user is an admin in the VM .

    So should add this same user in the test controller machine also. If yes , how can I add a user in one domain as a user in another domain. 

    Wednesday, October 3, 2012 6:16 AM
  • If your VM is in a domain, you should configure security by the book. Follow the steps in the article precisely.

    If your VM is in domain other than test controller, you should establish domain trust.

    If you VM is in a workgroup, you should use VM Prep Tool to install TFS agents, and disable firewall on agent.


    Regards, Dmitry

    Wednesday, October 3, 2012 8:44 AM
  • Thanks Demchuk for your kindly help.

    Hi Nikhil Rajan,

    I agree with Demchuk's opinion, and how about your issue now? Have you resolved it?

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, October 4, 2012 8:16 AM
    Moderator
  • Yes the issue has been resolved. I only needed to run as the user , i was not doing that ... but now the test agents are registered with the test controllers , but the status of the test agent is shown as disconnected.

    Any help on this guys 

    Thursday, October 4, 2012 10:35 AM
  • Hi Nikhil,

    Do you mean configure the test agent run as Interactive process?

    And I happened to encountered the same issue as yours today, and I resolved it by re-applying settings in the test controller: in the Configure Test Controller dialog click the "Apply Settings" button (it is OK even if you do not make any changes). After that, you should be able to have test agent connected to the controller successfully.

    If my above suggestion does not help you, please take a look at the event logs in the Event Viewer, and then post here the useful error message.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Friday, October 5, 2012 9:26 AM
    Moderator
  • The issue was  solved when i restarted the test agent .. the status is online now ..
    Friday, October 5, 2012 9:37 AM