locked
Installation problem with V0.3? RRS feed

  • Question

  • Is there a known installation problem with Small Basic V0.3? I've installed it several times now, and when I try to run it I immediately get the "Microsoft Small Basic has stopped working" message.
     
    Thursday, February 12, 2009 2:36 PM

Answers


  • Update or verify that you are using the. Net Framework v3.5 Sp1


    see the windows update or go this link Microsoft .NET Framework 3.5 Service Pack 1

    IMPORTANT:
    After installing the .NET Framework 3.5 SP1 package (either the bootstrapper or the full package) you should immediately install the update KB959209 to address a set of known application compatibility issues.


    my problem was solved so.
    • Proposed as answer by MaCsousa Thursday, February 12, 2009 10:23 PM
    • Marked as answer by Vijaye Raji Friday, February 13, 2009 6:09 AM
    Thursday, February 12, 2009 10:20 PM

All replies

  • Please check existing posts before starting a new thread. See Important: Problems on non_US operating systems.
    Thursday, February 12, 2009 3:43 PM
  • TonyNC, could you please refresh your cache and try the donwload again?  You should get a v0.3.1 build that hopefully fixes your problem.

    I'm unsure as to the problem seen by Stendec though.  Stendec, do you have any information on the exception that you're seeing?  Would it be possible to, say get the name of the exception?  (If you have VS installed on any one of these machines, it'd be even better)

    If you want instructions on how to debug into the program, please feel free to email me at vijayegatmicrosoftdotcom

    Thanks for your help on this Stendec.
    Thursday, February 12, 2009 4:57 PM
  • Thanks for responding.  I'm running the US version of Vista. I've downloaded the file several times and I continue to get this error.
    Thursday, February 12, 2009 9:56 PM

  • Update or verify that you are using the. Net Framework v3.5 Sp1


    see the windows update or go this link Microsoft .NET Framework 3.5 Service Pack 1

    IMPORTANT:
    After installing the .NET Framework 3.5 SP1 package (either the bootstrapper or the full package) you should immediately install the update KB959209 to address a set of known application compatibility issues.


    my problem was solved so.
    • Proposed as answer by MaCsousa Thursday, February 12, 2009 10:23 PM
    • Marked as answer by Vijaye Raji Friday, February 13, 2009 6:09 AM
    Thursday, February 12, 2009 10:20 PM
  • MaCsousa

    You the man!  Works now!
    Thursday, February 12, 2009 10:49 PM
  • Yes, problem solved.
    .net 3.5 SP1 does not seem to be a critical update, so it had passed me by completely. Thanks.
    Friday, February 13, 2009 11:37 AM
  • This is the exception I get when running on a US Vista x86 install. 

    System.TypeLoadException was unhandled

    Message: Could not load type 'System.Windows.SplashScreen' from assembly 'WindowsBase, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'.

    I will try updating .net 3.5 and see what happens.

    Crewdawg
    Friday, February 13, 2009 9:15 PM
  • Thanks, that fixed it!
    Saturday, February 14, 2009 2:48 AM