none
Can't run 2013 workflow on document in Sharepoint RRS feed

  • Question

  • I have install sharepoint 2013 and add workflow in it. No error reported.

    But everytime I create a workflow and run it on a document, it't started and then reported as cancelled with a http 500 error. It works fine on list item.

    No logs about this problem found, so I tried to find the problem by fiddler. I found that everytime the workflow service tries to execute a POST action, it issues a POST with nothing in bearer field, and then issues a POST with a token in bearer field. The first POST get a 401 error, and the second one get a 500 error, with a error message saying "need to check out the document first". But in fact the workflow just finishes with nothing done. Then the state of the workflow is set to cancelled.

    The communication is based on http, not https. I have tried to restart iis and workflow service, but it didn't works. Restart the conputer didn't work either.

    Anybody could help me? Thanks very much.

    • Edited by yxjing Thursday, December 13, 2012 11:11 AM
    Wednesday, December 12, 2012 11:10 AM

All replies

  • Hello, when you configured the workflow service with Register-SPWorkflowService did you include the AllowOAuthHttp flag? This is required for HTTP support (for example in development environments).
    Tuesday, December 18, 2012 7:26 PM
  • Hello, when you configured the workflow service with Register-SPWorkflowService did you include the AllowOAuthHttp flag? This is required for HTTP support (for example in development environments).

    Yes, I did it following the installing guide on MSDN.
    Thursday, December 20, 2012 6:23 AM
  • In that case, I'd suspect that the initial SharePoint configuration, including the User Profile Application service and the Token Service, did not complete successfully. Have you attempted to configure a new farm environment from scratch? The latest instructions are available at http://msdn.microsoft.com/en-us/library/jj163276.aspx.
    Wednesday, January 9, 2013 2:56 AM