none
Error Opening docx documents in WordViewer

    Question

  • Hello,

    I can't open documents in Wordviewer created in Office 2007 The error: "There was an error opening the file." (In my win7 embedded system created by windows embedded standard 7)
    I tried installing & reinstalling Wordviewer and the File Format Converter from Microsoft and all possible updates from Microsoft.

    As the same problem, have the similar error in Excleviewer(The converter failed to save the file) and PowerpointViewer(The converter failed to save the file).
    I don't konw the reason.
    Can you help me.
    Wednesday, March 3, 2010 9:40 AM

All replies

  • Hi Tracy,

    I'd be happy to help you, but I need to know some background information first:

    1) Which of our releases are you using? (CTP1, CTP2, or RC)
    2) Is any more information given with your error?  Does this only happen when trying to open .docx files, not regular .doc files?
    3) What packages have you included in your image?  Do you have an answer file you can share?  There's a possibility the necessary dependencies are not include in the image.
    4) Have you tried our Compatible Applications webpage?  http://www.windowsembedded.com/standardapplicationtemplates  On this page, there are templates for the Office viewer programs which you can download and use in ICE when creating your image (by merging them with the answer file).  This helps ensure that all of the necessary dependencies are included for the Office Viewers to install and run.

    Thanks!

    JT

    Wednesday, March 3, 2010 5:36 PM
  • Hi JT,

          I will give you some information about this win7 embedded system. 
        
          1)I used Rc to build this system.
          2)I Install all packages which include compatile package.(File Format Converter),  After install these packages, use Wordviewer to opening .docx files that there have an error.(There was an error opening the file),  .doc files are ok; use ExcelViewer to opening .xls files that prcoess will be crash,  open .xlsx files that have an error(The converter failed to save the file); use PowerponitViewer to opening .pptx files that have an error(The converter failed to save the file),  .ppt files are ok.
          3).net framwork (2.0,2.0 client,3.0 client, 3.5 client), Application Support (COM OLE, COM+, Win32), Boot Environments(Windows Boot), Browers(IE8), Data Access and Storage(Windows Data Access), Data Integrity(Shadow Copy Volume Interface), Device and Printers(Decice Framework,Device User Experience,Driver Framworks,standard windows USB), Diagnostics(Common Diagnostic Tools, User), Embedded Enabling Features(Custom Logon Desktop,"Edition Branding",Hide Boor Screens,Message Box Default Reply), Fonts(TrueType Fonts, Western Fonts), Graphics and Multimedia(Audio and Video Engines adn Media Founction, DirectX and Windows Device, Graphics Platform, "Premium Codecs", Windows Media Player 12), Internet Information Services-IIS (Windows Process Activation), Management (Power Management),System Management(Group Policy Management, MMC, System Management Administrative Tools,System Management Utilitie,WMI), Networking ("BASE", BITS,Domain Services, IRDA and UNIMODEM ,Network Access Protection, Quality of Service, SRS, Small Networking Services, Telephony Api, Windows Firewall, Wireless Networking) ,Security(Active Directory Rights, Application Security, Security Base, Windows Security Center), System Services(Core file System, File compression, Windows Installer ), User Interface(Accessibility, Command prompt Shell,Search Indexing, Tablet PC Support, Text Services Framwork),Windows Shell(Shell Controls and UI,Shell Foundation),LanguagePack(en-us),"Update","Product","Driver"(Scsiadapter<Ms VHD HBA>,Sdhost<Secure Digital Bus Host Contraoller>,Media<KS,MS Trusted Audio Drivers,Ms UAA,Ms WDM,WDM,Wave Audio Driver>)
          4)Merging them with my answer file and resolve dependencies .   But still have those errors.  *_*

    Thank you!
    Thursday, March 4, 2010 1:51 AM
  • So, it appears that there has been an update to the Microsoft Office Compatibility Pack since we created the template for the RC build (that update is here: http://www.microsoft.com/downloads/details.aspx?familyid=941b3470-3ae9-4aee-8f43-c6bb74cd1466&displaylang=en )

    Because of that update, 2 new dependencies have been brought in.  Use your current answer file, but also add 1) Powershell and 2) FS-RemoteClient.  From our quick internal testing, that should resolve your issue.

    Thanks for bringing this to our attention!
    Tuesday, March 9, 2010 12:00 AM
  • Hi JT,
         I add  1) Powershell and 2) FS-RemoteClient to my current answer file. The Wordviwer and Execlviewer are OK.  But the PowerpointViewer still have an error(The converter failed to save the file) that open *.pptx file.
         Are there some other components need to add ?

    Tuesday, March 16, 2010 5:48 AM
  • Thanks for the update Tracy. We'll do more investigation and get back to you.
    Tuesday, March 16, 2010 7:58 PM
  • Hi Tracy,

    We haven't been able to figure out or reproduce the problem you are seeing with PPT Viewer.

    Does this happen with all pptx files you try to open?  How many have you tried?  Would you be able to send us or link us to a file that you are having trouble with?

    Friday, March 26, 2010 6:14 PM
  • the same thing keeps happening to me that was happening to stacy

    help

    Friday, May 11, 2012 1:41 AM
  • I'm sorry to hear that.  Does this happen for Word, Excel, and PPT viewers?  Just one of them?  What is in your configuration?  Is it the exact same error Stacy was seeing?
    Friday, May 11, 2012 3:44 PM