locked
Disable PushKit Warning RRS feed

  • Question

  • User80393 posted

    Does anyone know how to disable this warning in Xamarin Studio:

    Warning MT0049: PushKit.framework is supported only if deployment target is 8.0 or later. PushKit features might not work correctly. (MT0049)

    I do not use PushKit in my App. But i do want to have deployment target set to 7.0. This warning is a annoying because it shows up all the time. That way I'm starting to just ignore the warnings. However, this is not XCode, so it would be awesome if warnings only show up when they are relevant for me.

    Thursday, October 23, 2014 8:59 AM

Answers

  • User37696 posted

    Change your linker settings to Link SDK Assemblies and the unused PushKit framework code will be linked away - removing this warning message.

    If your app actually uses PushKit, the linker would not remove this and things should work as expected. In that scenario, it's good to know that PushKit only works on iOS 8+ - hence the warning.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, February 12, 2015 5:25 PM

All replies

  • User4625 posted

    I get the same thing. Nothing changed except updating to the latest Xamarin toolset. Is this connected with use of HTTP web requests in the app?

    Thursday, October 23, 2014 4:57 PM
  • User39 posted

    Are you linking your apps (in the project's iOS Build options, what is "Linker Behavior" set to)?

    Monday, October 27, 2014 4:02 PM
  • User4625 posted

    It was set to "Don't link" for some configurations. Switched them all to "Link SDK assemblies only" and the warning went away!

    Monday, November 3, 2014 6:54 PM
  • User502 posted

    If you want the configuration to "Enable incremental builds" I believe the Linker behavior should be set to Don't Link otherwise the settings work against each other. So I'm thinking for developer builds the best compromise is to ignore that error knowing it won't be there when building for release.

    Monday, November 3, 2014 7:05 PM
  • User88 posted

    Did anyone figure out how to get rid of this warning? I am also seeing it on my debug builds. I've been ignoring it for now, but it would be nice to get rid of it.

    Friday, November 7, 2014 7:49 PM
  • User34323 posted

    I have it, too.

    Monday, December 29, 2014 11:02 AM
  • User707 posted

    This warning has been there for ages (months) and is still in 8.4.0.47 in Debug with "Don't Link". When will it be fixed??

    Monday, December 29, 2014 11:05 AM
  • User67478 posted

    I also get this warning after updating Xamarin.iOS to 8.6.0.51. Before I didn't had this warning. What should I do?

    Currently I tried that from Anton Venema and it seems to work. But why do I need that?

    Tuesday, January 13, 2015 11:18 AM
  • User42331 posted

    We have this after upgrading to 8.4.0.47 with linker behavior set to link all assemblies.

    Thursday, January 29, 2015 6:42 PM
  • User37696 posted

    Change your linker settings to Link SDK Assemblies and the unused PushKit framework code will be linked away - removing this warning message.

    If your app actually uses PushKit, the linker would not remove this and things should work as expected. In that scenario, it's good to know that PushKit only works on iOS 8+ - hence the warning.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, February 12, 2015 5:25 PM