none
Proxy settings for a participant RRS feed

  • Question

  • I have a service that needs to use a proxy.

    Is it possible to add proxy settings to one participant?

     

     

    Wednesday, October 31, 2007 10:32 AM

Answers

  • Hi Roel,

     

    First of all, if your participant web service is required to use a proxy, the Session component would need proxy settings to communicate with that web service. This can be done by adding the proxy settings to the web.config file. But these settings are limited to the addition of proxy server address.

     

    However, another option could be having a wrapper web service in your local intranet zone and using this wrapper web service for all the communication with Session component. The methods in the wrapper web service can then directly invoke the targetted web service (of course, you would have to have the reference of the traget web service and all calls should have the proxy settings attached to it.).

     

    Hope this helps,

    Rishabh Kapoor.

    Saturday, November 3, 2007 9:53 AM

All replies

  • Hi Roel,

     

    First of all, if your participant web service is required to use a proxy, the Session component would need proxy settings to communicate with that web service. This can be done by adding the proxy settings to the web.config file. But these settings are limited to the addition of proxy server address.

     

    However, another option could be having a wrapper web service in your local intranet zone and using this wrapper web service for all the communication with Session component. The methods in the wrapper web service can then directly invoke the targetted web service (of course, you would have to have the reference of the traget web service and all calls should have the proxy settings attached to it.).

     

    Hope this helps,

    Rishabh Kapoor.

    Saturday, November 3, 2007 9:53 AM
  • Hi Roel,

     

    Is your query resolved? If yes, then please close the thread by marking the helpful post as the answer.

     

    Thanks,

    Rishabh Kapoor

     

    Wednesday, November 21, 2007 7:06 PM
  • Hi Roel,
    this is how you should add the proxy configuration in session web.config file
    <configuration>
      <system.net>
        <defaultProxy>
          <proxy
            usesystemdefaults="true"
            proxyaddress="http://192.168.1.10:3128"
            bypassonlocal="true"
          />
          <bypasslist
            <add address="[a-z]+\.contoso\.com" />
          </bypasslist>
        </defaultProxy>
      </system.net>
    </configuration>
    thanks
    subhadip
    Thursday, November 22, 2007 5:52 AM