locked
Can't create App package

    General discussion

  • Hi,

    since recently I get this error when trying to create app package from Visual Studio Express:

    ---------------------------
    Windows App Certification Kit
    ---------------------------
    The Windows App Certification Kit experienced the following failure while validating your app.

     

    The {0} cannot continue testing since the specified Windows Store App was not found. Please verify that the packagefullname is correct.

    ---------------------------
    OK   
    ---------------------------

    The only option I have is to cancel. I have tried the solution with unistalling apps through PowerShell but it didn't work since none of the InstallLocation fields in Get-AppxPackage are empty.

    I have also tried to re-create the app with a different name but I always get this error.

    Please help or give me instructions. Thanks!

    Tuesday, December 18, 2012 11:34 AM

All replies

  • The error msg seems to indicate that your app has not installed on your Win8 computer or for reason it is not detecting it. I'd suggest that you troubleshoot the issue by trying one of the following:

    1) Replace the package GUID value with a new one. Compile and run the app to make sure that it is working (and installed on your computer). Then, run the certification kit and select the app from the list to test.

    2) If you still have the same issue, try to create a new app with a new app name. Run the certification kit and pick up the new app from the list to test.

    Let us know if and how you resolve the issue.

    Tuesday, December 18, 2012 9:14 PM
  • Thank you for your help. I'm sorry I haven't been able to test and report sooner.

    I have tried your solution 2) before and it didn't work.

    Today I have tried your solution 1). I hav created a new GUID from Tools -> Create GUID and replaced it in the .jsproj project file. I have recompiled the app, made sure that it was installed on my system and tried running the certification kit. Again I got the same error.

    So I still haven't resolved the issue.

    Wednesday, December 26, 2012 3:13 PM
  • I have re-installed Windows and Visual Studio and the issue is now gone. I successfully created the app package within the new installation.

    Saturday, December 29, 2012 11:02 AM