locked
Load Report Failed RRS feed

  • Question

  • User2059853125 posted

    I am trying to generate a simple crystal report on the website. Getting the below exception:

    CrystalDecisions.Shared.CrystalReportsException: Load report failed. ---> System.Runtime.InteropServices.COMException (0x80004005): The system cannot find the file specified. at CrystalDecisions.ReportAppServer.ClientDoc.ReportClientDocumentClass.Open(Object& DocumentPath, Int32 Options) at CrystalDecisions.ReportAppServer.ReportClientDocumentWrapper.Open(Object& DocumentPath, Int32 Options) at CrystalDecisions.ReportAppServer.ReportClientDocumentWrapper.EnsureDocumentIsOpened()

    I am new to asp.net, came from java background.

    Pls provide me the cause and solution to above problem

    Wednesday, July 4, 2012 7:48 AM

Answers

  • User622904130 posted
    rptDoc.FileName = Server.MapPath("../Reports/Yourreport.rpt")
    rptDoc.Load(Server.MapPath("../Reports/Yourreport.rpt"))

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, July 4, 2012 9:02 AM
  • User1196771204 posted

    hi there,

    In order to run Crystal Report properly, there are several things you need to check:

    1. Please make sure the crsytal report version that you used on your code MATCHES the one you instal on the server
    2. Please make sure the crsytal report assemblies that you used on your code MATCHES the one you instal on the server 
    3. Please make sure you allow FULL TRUST mode on your site/application
    4. Please make sure you set the application pool to run under LOCAL SERVICE permission
    5. Please make sure you copy the crystalreportviewer folder to your working folder.

    For Crystal Report hosting, you can always contact asphostcentral.com. Thank heaps!

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, July 10, 2012 1:51 AM

All replies

  • User622904130 posted
    rptDoc.FileName = Server.MapPath("../Reports/Yourreport.rpt")
    rptDoc.Load(Server.MapPath("../Reports/Yourreport.rpt"))

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, July 4, 2012 9:02 AM
  • User1196771204 posted

    hi there,

    In order to run Crystal Report properly, there are several things you need to check:

    1. Please make sure the crsytal report version that you used on your code MATCHES the one you instal on the server
    2. Please make sure the crsytal report assemblies that you used on your code MATCHES the one you instal on the server 
    3. Please make sure you allow FULL TRUST mode on your site/application
    4. Please make sure you set the application pool to run under LOCAL SERVICE permission
    5. Please make sure you copy the crystalreportviewer folder to your working folder.

    For Crystal Report hosting, you can always contact asphostcentral.com. Thank heaps!

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, July 10, 2012 1:51 AM