locked
Is System.Security supported in Portable Class library RRS feed

  • Question

  • hi,

    Is there a list of libraries that are supported by the "Portable Class" ?

    I am trying to use SecureString and it's giving an error "cannot resolve symbol".

    The project is target for .NEt framework 4 and higher, Silverlight 4 and higher, Windows Phone 7 and higher and .Net for Windows Store apps

    Using VS2012

    Any help is appreciated.

    Thank you.


    • Edited by RoshDsa Monday, November 5, 2012 4:51 PM
    Monday, November 5, 2012 4:49 PM

Answers

  • Hi RoshDsa,

    Welcome to the MSDN Forum.

    Not all, such as CodeAccessPermission is not supported.

    You can try this way to verify a class is supported by portable class library: http://msdn.microsoft.com/en-us/library/gg597391.aspx#members 

    You can also look in the Version Information section of a reference topic for a note indicating that a type or member is supported in the Portable Class Library project, as shown below.

    Portable Library Version Information

    Best regards,


    Mike Feng
    MSDN Community Support | Feedback to us
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by RoshDsa Tuesday, November 6, 2012 2:36 PM
    Tuesday, November 6, 2012 11:21 AM