none
How to enable Outlook 2013 macros RRS feed

  • Question

  • I have a macro that I wrote in VBA  not quite two years ago to automate a task for me in Outlook 2013.  This macro was signed with a digital certificate I created for myself.  Macro security was set to Notifications for digitally signed macros, all other macros disabled.

    Up until a few days ago, I was having no problems.  Then, out of the blue (at least, I cannot recall any change that would have triggered my problem), Outlook 2013 started refusing to run my macro.  I get the following message:

    "The macros in this project are disabled.  Please refer to the online help or documentation of the host application to determine how to enable macros."

    I have tried many different tricks I have read about on the Internet, but with little to no success.  I have completely deleted the VbaProject.OTM file and removed the certificate I created from the computer, both from the Personal store and the Trusted Publishers store.  (Incidentally, it took forever for Outlook to not see me as a Trusted Publisher: I could not remove myself as a Trusted Publisher in the local account, but running Outlook with administrator privileges did not show me as a Trusted Publisher that could be removed.  I think it was only after I removed the certificate from the Trusted Root Certificate store using the Console (mmc.exe) that Outlook finally stopped showing me as a Trusted Publisher.)

    After a reboot of the computer, I pasted by code into a newly created (by Outlook) VbaProject.OTM file.  The code ran once, and I thought the problem was solved.  I then shut down and restarted Outlook, and the problem reappeared.

    I have tried the above approach both with and without signing the code with a new self-signed certificate.  It makes no difference.  The code runs when I first create the VbaProject.OTM file; the next time Outlook starts, I get the dialog box again.

    The macro will run if I set the macro security to Enable all macros.  But I do not want to have the macro security disabled: that was the point in self-signing the code.  And since I have to shut down and restart Outlook each time I change the macro security level, enabling all macros just to run my code would be very time-consuming (I run this macro several times a day).

    Some particulars about my computer:
    Windows 10 Home edition, 64-bit
    Outlook 2013, part of Office 2013
    The code does require a reference to the Microsoft Word 15.0 Object Library (although I can't see why that would make a difference).

    Any help in getting Outlook to let my macros run again would be greatly appreciated!

    Ariel S. Rogson

    Friday, October 21, 2016 4:27 PM

All replies

  • Hello Ariel,

    Looks like you need to purchase a certificate from a trusted vendor, for example, DigiCert .


    [custom.development]

    Friday, October 21, 2016 9:29 PM
  •  

    Hi,

    Sorry that we failed to reproduce your issue. The macro setting could work after we sign the project with self-signed digital certificate.

    How do you create the digital certificate?

    I suggest you sign the project with other valid certificate like some certificates in the Trusted Publishers or in the Trusted Root Certification Authorities.

    Regards,

    Celeste


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, October 26, 2016 8:02 AM
    Moderator
  • I have the same problem. It started about a week ago.

    When I lower the macro security settings this is the message that appears when I try running my macro the first time after I start up outlook.

    I have not made any changes to the macros for the last two months.

    As you can see the button to "Trust all documents from this publisher" (in swedish) is grayed out and I can't click it.

    I and a few others in the office use my macro at least a few times per day so this is very annoying.

    BTW my macro is signed by a certificate created by selfcert.exe and it is installed as a trusted root certificate.

    Wednesday, October 26, 2016 1:33 PM
  • Hi,

    What is your specific version of Office?

    I test in 15.0.4420.1017 64bit. It works for me to use a self certificate.

    My steps:

    Ensure the macro setting is Notifications for digitally signed macros

    Create a macro

    Create a certificate by using Selfcert.exe

    Sign the macro

    Restart the Outlook

    Run the macro, get the following 


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, October 27, 2016 1:21 PM
    Moderator
  • I have Office 15.0.4867.1003 32bit.

    Do you think it could be this version thats the problem? I guess that could explain why is stopped working for all of us in the office at roughly the same time. The same macros works fine on an installation of Office 2010

    Thursday, October 27, 2016 4:17 PM
  • Hi,

    Recent update to 15.0.4867.1003 might cause the issue.

    Testing in this version, the macro setting fails though we have signed the project with selfcert.

    I would suggest follow the link below to revert to an earlier version.

    https://support.microsoft.com/en-us/kb/2770432

    Besides, If the issue is urgent for you, I suggest you contact the Microsoft professional support.

    If the support engineer determines that the issue is the result of a bug, the service request will be a no-charge case and you won't be charged.

    Please visit the below link to see the various paid support options that are available to better meet your needs. 

    http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    Sorry for any inconvenience and have a nice day! 

    Regards,

    Celeste



    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Friday, October 28, 2016 11:25 AM
    Moderator
  • Thank you very much!

    Reverting to 15.0.4859.1002 solved the problem!

    Friday, October 28, 2016 12:03 PM
  • Hello,

    I've got the same issue with 15.0.4875.1001.

    When enable Notifications for digitally signed macros, no notification appears and macros are disabled.

    When enable Notification for all, I've got the notification then the macro runs fine.

    Friday, December 23, 2016 11:02 AM
  • The issue does not exist in the newest version of Office 2016. If possible, i suggest you use Office2016.

    For Office2013, i suggest you use command line officec2rclient.exe /update user updatetoversion=15.0.4859.1002 to revert the earlier version based on the KB:

    How to revert to an earlier version of Office 2013 or Office 2016 Click-to-Run


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, December 27, 2016 10:03 AM
    Moderator
  • We have a lot of computer to change...

    Is a patch planned?


    EDIT: I confirm Office 2016 works fine and version 15.0.4885.1000 has the same issue.

    Wednesday, January 4, 2017 10:53 AM