locked
No Design View for Metro Apps

    Question

  • I cannot design anything I always get this error...

    System.Runtime.InteropServices.COMException

    This Metro style application does not support the contract specified or is not installed. (Exception from HRESULT: 0x80270254)

       at Microsoft.Expression.HostUtility.AppPackage.NativeMethods.IApplicationActivationManager.ActivateApplication(String appUserModelId, String activationContext, ActivateOptions options, Int32& processId)   at Microsoft.Expression.HostUtility.AppPackage.WrtUtility.ActivateApplication(String appUserModelId, String activationContext, Object site)   at Microsoft.Expression.HostUtility.Platform.TailoredDomainFactory.CreateDesignerProcess(String applicationPath, String clientPort, Uri hostUri, IDictionary environmentVariables, Int32& processId, Object& processData)   at Microsoft.Expression.DesignHost.Isolation.Primitives.ProcessDomainFactory.ProcessIsolationDomain..ctor(ProcessDomainFactory factory, IIsolationBoundary boundary, AppDomainSetup appDomainInfo, FrameworkName targetFramework, String identifier)   at Microsoft.Expression.DesignHost.Isolation.Primitives.ProcessDomainFactory.CreateIsolationDomain(IIsolationBoundary boundary)   at Microsoft.Expression.HostUtility.Platform.TailoredDomainFactory.CreateIsolationDomain(IIsolationBoundary boundary)   at Microsoft.Expression.DesignHost.Isolation.Primitives.IsolationBoundary.Initialize()   at Microsoft.Expression.DesignHost.Isolation.Primitives.IsolationBoundary.CreateInstance[T](Type type)   at Microsoft.Expression.DesignHost.Isolation.IsolatedExportProvider.Initialize()   at Microsoft.VisualStudio.ExpressionHost.Services.VSIsolationService.CreateExportProvider(IIsolationTarget isolationTarget, ICatalogFactory catalogFactory, IExportFilter filter)   at Microsoft.Expression.DesignHost.Isolation.IsolationService.CreateLease(IIsolationTarget isolationTarget)   at Microsoft.Expression.DesignHost.IsolatedDesignerService.CreateLease(IIsolationTarget isolationTarget, DesignerServiceEntry& entry)   at Microsoft.Expression.DesignHost.IsolatedDesignerService.CreateDesignerViewInfo(IIsolationTarget isolationTarget, IHostSourceItem item, IHostTextEditor editor, CancellationTokenSource cancelSource)   at Microsoft.Expression.DesignHost.IsolatedDesignerService.<>c__DisplayClass1b.<CreateDesigner>b__19()   at System.Threading.Tasks.Task`1.InnerInvoke()   at System.Threading.Tasks.Task.Execute()

    What is the solution?

    • Moved by Allen Chen - MSFT Monday, March 12, 2012 7:00 AM not a javascript question (From:Building Metro style apps with HTML5/JavaScript)
    Monday, March 12, 2012 3:11 AM

All replies

  • Hi Anthony,

    There are few known issues with XAML Designer in Beta build of Visual Studio 11 Beta. Can you please try the work-around mentioned in the blog and see if this works for you? If not, please get in touch with me at navits at microsoft dot com and I can investigate this issue.

    Work-around: http://blendinsider.com/xaml/known-issue-xaml-designer-in-visual-studio-11-beta-crashes-on-launch-2012-03-07/

    -Navit Saxena

    Monday, March 12, 2012 3:58 PM
  • Got the same problem: HRESULT 0x80270254.

    solved it with enabling windows firewall service which was disabled.

    regards

    • Proposed as answer by xxxifan Sunday, March 25, 2012 2:21 PM
    Friday, March 23, 2012 1:25 PM
  • Hi there,

    Before enabling the firewall :), were you able to successfully build and run a Blank C# application (without consideration of the designer)?

    Thanks!
    Unni


    Unni Ravindranathan, Program Manager, Microsoft Expression This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, March 23, 2012 6:34 PM
  • same here,i got the Exception from HRESULT: 0x80270254 too

    and when i running this app,i got two errors even a blank application

    ERROR : DEP0700 : Registration of the app in the layout folder "c:\users\smith\documents\visual studio 11\Projects\Application2\Application2\bin\Debug\AppX" failed. 

    and

     0x800706D9 : While installing the b778ea01-5bf3-4fe9-982c-0dfc150d28cb_1.0.0.0_neutral__ns6y6v1178198 package, the system failed to register the windows.repositoryExtension extension due to the following error:

    and my windows firewall is disabled too,so i'll go to try STOSB's method to see if it work..

    Sunday, March 25, 2012 2:15 PM
  • Got the same problem: HRESULT 0x80270254.

    solved it with enabling windows firewall service which was disabled.

    regards


    yeah!thank you very much!after i enable the firewall service,it works fine again!
    Sunday, March 25, 2012 2:22 PM
  • My installation was working fine.  I installed some other software and then started to get this error. None of the above solutions worked.  I went into control panel and ran the Repair option.  it forced a reboot and then everything went back to working.
    Friday, March 30, 2012 9:10 PM
  • My firewall service is abled, but the designer doesnot work yet.

    Even though the designer does not work, it can run successfully.

    Do you know why?


    win8

    Friday, April 20, 2012 11:20 AM
  • Hi All,

    Can you please installing latest Windows8 Release Preview and Visual Studio 2012 RC release. We have made lot of fixes in this area and this issue should not repro on RC bits.

    -Navit Saxena

    Thursday, May 31, 2012 8:44 PM
  • I had the same problem/error message when I used Visual Studio on a VM deployed in Azure.  The issue I had was that I was using the build-in administrator account which does not allow the app to be activated.

    I created another account with administrator privileges and was able to use both Visual Studio and Blend to modify XAML files.

    Saturday, July 21, 2012 9:08 PM