Strange database behaviour after running UITest RRS feed

  • Question

  • User56293 posted

    I have been working on some local UITests which include logging into our server and downloading data, this data is then stored in a SQLite database on the device. When I now come to debug the application, when the application launches I am taken directly to a state where the database has been restored from a previously saved state. I have tried clearing data aswell as uninstalling the application however when I try again I am still taken to this previously saved state.

    When running a UITest, is the application installed as normal? Is the database location going to be the same?

    I have tried debugging on another device, which hasn't been used for the UITests and the database is not restored, as it doesn't have a previously saved state so I am pretty sure it is a combination of the device I previously run the UITests on and the application.

    By restored, I mean via the standard SQLite interface and no specific restore logic I have in my code.

    I have also tried changing the name of the database and this has allowed for the correct initial state to be achieve when debugging the application, however this is slight overkill as there must be a way to remove this rouge database.

    I am using an older version of Xamarin.UITest (1.3.8) so could this be a known issue with that version?

    Is there any other way of removing this rouge database? I have tried a couple of file managers but they don't seem to see the database.

    I am running on a Samsung A5.

    Friday, November 17, 2017 3:23 PM

All replies