none
CMake appcrash while generating cache

    Question

  • Hi! I'm always getting APPCRASH when CMake tries to generate the cache. What's happening?

    The project is as simple as could be to test.

    CMakeLists.txt

    cmake_minimum_required(VERSION 3.6)
    
    project(Eldritch Horror)
    
    set(SOURCES src/main.cc)
    
    add_executable(eldritch ${SOURCES})
    

    main.cc

    #include <iostream>
    
    int main(int argc, char* argv[]) {
      return 0;
    }


    Installed components:

    • Visual Studio core editor
    • Static analysis tools
    • Visual Studio C++ core features
    • VC++ 2017 v141 toolset (x86,x64)
    • .NET Framework 4.6.1 SDK
    • .NET Framework 4.6.1 targeting pack
    • Visual C++ tools for CMake
    • C++/CLI support

    Friday, March 24, 2017 8:14 PM

All replies

  • Hi Bledson,

    Welcome to MSDN forum.

    I test it on my side, everything is ok. Please do not use spaces in the name of project and have a try. Besides, you could ask questions about CMake in here: https://cmake.org/

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 27, 2017 9:00 AM
  • Hi,

    Is any update about your issue? 

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, April 6, 2017 8:52 AM