locked
Blend 4 RC cannot create Word Document RRS feed

  • Question

  • Environment:
    Windows 7 64Bit
    Office Professional2007
    Visual Studio 2010 RTM

    Repro:
    Click Export to Word

    Result:
    It may prompt saying "PortalApp.doc already exists do you want to replace it?" if so click yes
    Message Export Failed - Could Not Create the Word Document
    The Word document exists but it is empty

     

    Monday, April 19, 2010 4:29 PM

All replies

  • That's a tested scenario (Win7 64, Office 2007, and VS 2010 RTM), so there's some difference between your machine and our test machines. 

    Have you been able to export to Word in the past?  If not, have you installed the 2007 Office Primary Interop Assemblies from http://www.microsoft.com/downloads/details.aspx?familyid=59DAEBAA-BED4-4282-A28C-B864D8BFA513&displaylang=en?

    Monday, April 19, 2010 5:19 PM
  • I have never been able to export in the past (Blend 4 Beta) although I don't think that I ever tried with Blend 3. I just uninstalled and reinstalled PIA with the same symptoms. The PIA installation does not confirm that they are installed but they show up in Control Panel...Programs list.

    Thanks,
    Don

    Monday, April 19, 2010 5:43 PM
  • Can you export an empty project?  That is, create a new SketchFlow project and export immediately?

    (Trying to figure out if there is something unique to the project causing problems or unique to your machine)

    If you _can_ export an empty project, I'd love to see the project you're not able to export.  If you are free to send it, please send it to kellycan@microsoft.com

    Monday, April 19, 2010 6:10 PM
  • The project that I am working on was started from within Visual Studio. I created a Silverlight Business Application and then added a Silverlight Sketchflow project to the solution. To look for issues there I created a new project from Blend (which created it in the default directory). Without changing anything, trying to export the project shows the same symptoms (Could not create document) although SilverlightPrototype1.doc (1 KB in size but empty) is created.

    Office Diagnostics identified and fixed one problem but I can't readily see what the problem was and there is no change in the results.

    I checked the event log and there is nothing there - is there any other log that might be interesting?

    Thanks,
    Don

    Monday, April 19, 2010 7:14 PM
  • I'm afraid there's no additional log that I can point you to.  I've talked with the original developer, and we're both at a loss. 

    A few very low likelihood ideas as a result of how at a loss I am...

    Open Word and verify there are no corrupt files that could be blocking Blend from accessing Word.  I know that we've seen a few instances where a template was corrupt and Word wanted that fixed prior to letting us create documents.  Since we have no method of forwarding those dialogs onto users or knowing why Word isn't letting us create documents, the net result is "No export for you" without an explanation.  

    Is Word open when you're trying to export?  If so close it.  If it's closed, try opening it.  I know there was one weird bug where running Blend elevated and having Word open but not elevated caused the export to fail.  It was resolved no fix as it was such an odd scenario, but if we have users hitting it, maybe we should re-evaluate that. 

    I'll continue to ask around the office to see if anyone has ideas, and get back to you if I find out anything else to try.

    So sorry for the inconvenience,
    Kelly

     

    Monday, April 19, 2010 7:55 PM
  • OK, I closed Word and Outlook for good measure and the same problem occurred. Opened Word and still had the problem. Ran Blend as admin with Word closed and same problem.

    When I first closed Word and Outlook I checked in Task Manager to see if there was anything lurking out there. It turns out that every time you try to Export a new Process called WINWORD.EXE*32 is created and it is still there after the failure (I had about 6 of them).

    Try to save to C:\Windows\System32 and I get a proper error that Access to the path is denied and no file is created.

    I am not sure why this is creating a Doc file instead of docx but I have no problem creating Doc files manually.

    If you know the calls that Blend is making to the PIA I can write a little test of that to see if I can reproduce the problem.

    Thanks,
    Don

    Monday, April 19, 2010 9:04 PM
  • I am open to suggestions for anything else that I can try...

    It does appear that the file is getting created and messages that flash by imply that the content for the document is created, it just fails to put the content into the document.

    Don

    Saturday, April 24, 2010 8:24 PM
  • I am also not able to export, not even empty project. I have installed 2010 Office Primary Interop Assemblies but still the problem persists.

    May be I am doing something wrong as I have just started learning Blend.

    Please answer, it's very urgent.


    • Edited by SagarDabas Wednesday, February 13, 2013 7:00 AM
    Wednesday, February 13, 2013 6:46 AM
  • Its the same Problem for me. Microsoft Office Professional Plus 2010. Visual Studio Pro 2013.

    When i try to export a Blend Project without using a different Template it gives me Error 4248.
    When i try to use a Template Blend just says Could Not Create the Word Document.

    I tried to install the packages meant above.

    Somehow frustrating. 

    Thursday, February 13, 2014 12:02 PM