locked
TFS-PT -- defaultProxy? RRS feed

  • Question

  • I was having the issue described in this post, and the solution proposed fixed it. Does anyone know how to fix this with the TFS 2010 Power Tools Windows Shell extension?

    http://social.msdn.microsoft.com/Forums/en-US/tfsversioncontrol/thread/cec1cda4-93ac-404a-96a0-6c45910325ce/

    We're starting an investigation into this issue internally. We had a similar complaint about two weeks ago that came through customer support. It does not appear to be a TFS issue per se but rather something lower in the .NET Framework stack, having to do, as you mentioned, with automatic proxy discovery through the WPAD protocol.

    You already found that you can work around the issue by turning off proxy autodiscovery globally on your system. I want to make sure you know that you can also disable it on a per-application basis by using a .exe.config setting. Add the following node to your <configuration> node in the .exe.config file.

      <!-- Disable web proxy autodiscovery (download and compilation of javascript to determine proxy) -->
      <system.net>
        <defaultProxy enabled="false" />
      </system.net>

    The .exe.config for Visual Studio is %VSINSTALLDIR%\Common7\IDE\devenv.exe.config and it already contains a section in the .exe.config for System.Net. After adding the defaultProxy element, that section would look like this

        <system.net>
            <defaultProxy enabled="false" />
            <settings>
                <ipv6 enabled="true"/>
            </settings>
        </system.net>

    Hope this helps

     

     

    Friday, June 17, 2011 2:38 PM

Answers

  • Looking at one of the comments on the aforementioned post, "Jason" indicated that changing making the defaultProxy change to the TF.exe.config fixed using the TF executable from the command line. This also seems to fix the issue with TFS PowerTools.

    %VSINSTALLDIR%\Common7\IDE\TF.exe.config

      <system.net>
        <defaultProxy enabled="false" />
      </system.net>

    • Marked as answer by colinbashbash Friday, July 15, 2011 7:18 PM
    Friday, July 15, 2011 7:18 PM

All replies

  • Hi Colin,

     

    Thanks for your post.

     

    According that post, this issue caused by the default proxy in exe.config file of VS. Do you mean that how to do this setting(Defaultproxy enabled = “false”) with TFS 2010 Power Tools Windows Shell extension?

     

    The Windows Shell Extensions for Team Foundation Server provides integration with Windows Explorer and the common file dialogs. With this

    integration, you can perform many source control operations without having to run Visual Studio or a Team Foundation command-line tool. I don’t think we can set VS exe.config file using TFS 2010 Power Tools Windows Shell Extensions, so we can’t fix this issue using TFS 2010 Power Tools Windows Shell Extensions. For more information of TFS 2010 Power Tools Windows Shell Extensions, click Start>>All Programs>>Microsoft TFS 2010 Power Tools>Help>> Windows Shell Extensions.        


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, June 20, 2011 4:25 AM
    Moderator
  • Oops, sorry. Judging from your response, I'm not sure that I was being clear. 

    Problems I am having:

    1. When using Team Explorer, a Get Latest Version that should take 90 seconds, instead takes about 30 minutes.
    2. When using TFS Power Tools - Windows Shell Extension, a Get Latest Version that should take 90 seconds, instead takes about 30 minutes.

    Both problems are related to this: requests get routed through the external Proxy that our company has set up in "Internet Options". (I'm currently experiencing this issue in Windows 7. Not sure about WinXP)

    Problem 1 was able to be fixed by the aforementioned post. Problem 2 was not fixed by that post, and it is the one I submitted to this forum, in hopes of a solution.

    Please let me know whether you think there is a way to prevent the TFS PT - Windows Shell Extension from using the default proxy (Automatic Configuration Script) that is set up in Internet Explorer.

    Thanks for your help,
    Colin


    Monday, June 20, 2011 1:31 PM
  • Colin,

    I've moved this thread to he proper forum: TFS Power Tools. We can help you better here I feel.


    --Trevor H.
    Send files to Hotmail.com: "MS_TREVORH"
    Friday, June 24, 2011 3:20 PM
    Moderator
  • Thanks Trevor

    Is there any additional information that I could provide?

    ~Colin

    Wednesday, June 29, 2011 4:16 PM
  • Looking at one of the comments on the aforementioned post, "Jason" indicated that changing making the defaultProxy change to the TF.exe.config fixed using the TF executable from the command line. This also seems to fix the issue with TFS PowerTools.

    %VSINSTALLDIR%\Common7\IDE\TF.exe.config

      <system.net>
        <defaultProxy enabled="false" />
      </system.net>

    • Marked as answer by colinbashbash Friday, July 15, 2011 7:18 PM
    Friday, July 15, 2011 7:18 PM