locked
Cant debug on localhost RRS feed

  • Question

  • User482458310 posted

    Been working for over a year with Visual Studio 2005, debugging on localhost (IIS and file system) with no problem.  Recently installed Vis Web Developer 2008, and have been debugging on localhost (file system) with no problem.

    All of a sudden, when I click on Debug I get error message in IE, with error details stating:  "localhost" is not setup to establish a connection on port "49232" with this computer.

     I tried System Restore to latest point (an automatic Windows Update install), but the System Restore "did not complete successfully -- unspecified error".  Tried to restore to an even earlier point -- same thing.

    IE seems to work OK when URL is something like:

    http://localhost/mysite/mypage.aspx,  but throws the error when URL is

    like: http://localhost:49232/mysite/mypage.aspx

    Since system restore doesn't work, I'm dead in the water.

    Help will be GREATLY appreciated. 

     

     

    Monday, March 9, 2009 7:44 PM

Answers

  • User-1947561405 posted

    All our developers have the same problem today.

    Yesterday everything worked fine, but without anything being changed, we have the same problem today.

    We fixed it by replacing "::1 localhost" by "127.0.0.1 localhost" in the hosts file.

    Don't know why it worked yesterday and not today, but at least we can continue developing now.

    -- Pieter Jan

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, March 10, 2009 6:30 AM

All replies

  • User1439985827 posted

    That's a strange one. Perhaps you can try turning off any Virus Scanners / Windows Firefall temporarily to see if they are causing the problem? I had something similiar where a Windows Firewall rule wasn't playing well with local debugging.

    Monday, March 9, 2009 7:47 PM
  • User482458310 posted

    Tried turning off firewalls, still same result.

    Any idea where the "allowed" ports for "localhost" are specified?

     

    Monday, March 9, 2009 8:02 PM
  • User1747761241 posted

    Other safer things to try first.

    (never turn off the firewall without disconnecting internet or turning off modems first) 

    You might try just creating a new profile on the local machine and see if debugging works for that profile?  Have your collague sign on to your machine and test if it works for them? 

    Monday, March 9, 2009 10:14 PM
  • User1552370623 posted

     Hi,

    One possible thing to check is that in IE settings, on the advanced tab under section browsing, make sure that "disable script debugging" is unchecked for IE and other.

    Tuesday, March 10, 2009 12:56 AM
  • User-1947561405 posted

    All our developers have the same problem today.

    Yesterday everything worked fine, but without anything being changed, we have the same problem today.

    We fixed it by replacing "::1 localhost" by "127.0.0.1 localhost" in the hosts file.

    Don't know why it worked yesterday and not today, but at least we can continue developing now.

    -- Pieter Jan

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, March 10, 2009 6:30 AM
  • User1574681042 posted

     Thanks, just spent an hour and a half in the middle of an urgent project trying to fix that!

    Tuesday, March 10, 2009 7:06 AM
  • User482458310 posted

    WOW -- that did the trick.

    How in the world did you come up with that?

    BTW, I suspect that an automatic Windows Update is what caused the mischief to begin with.

    THANKS VERY MUCH.

    Tuesday, March 10, 2009 3:01 PM
  • User-226510127 posted

    Thanks this worked for me too. It would be interesting to know what caused it to quit working.

    replacing "::1 localhost" by "127.0.0.1 localhost"

     

    Tuesday, March 10, 2009 10:10 PM
  • User-1575438868 posted

    This update caused this:
    Definition Update for Windows Defender - KB915597 (Definition 1.53.256.0)

    It caused a removal of the IP mapping to localhost in the hosts file located in
    C:\Windows\system32\drivers\etc\

    You should include this line to the hosts file:
    127.0.0.1 localhost


    See this thread for details:
    http://forums.cnet.com/5208-6132_102-0.html?threadID=334042

    Thursday, March 12, 2009 5:11 AM