Read only keeps reverting back. RRS feed

  • Question

  • A couple days ago something changed on my computer while playing a game called Terraria.

    Now it crashes once it tries to save.

    I checked online and eventually came to the conclusion everything, including the save folder for the game Terria, under 'Documents' now keeps reverting back to 'Read Only'.

    So far I have tried everything on this website but nothing worked and now here I am.

    At the time I had the antivirus Norton installed and working but I believe that that was what caused the problem so I uninstalled it for now.

    If someone could help me with this I'd be very grateful.

    Monday, November 22, 2021 10:26 PM

All replies

  • Try right clicking on the folder, In the properties, have a look at Security, also check under advanced.

    try to find out what context is the program saving under, probaly system or your account,

    then see if you have that right, remember you might have some nestet deny rights.

    also are you on a work pc ? perhaps these rights settings have been set via gpo, og the folder is a redirect to a share somewhere.

    try running the folder from another location..

    Happy hollydays hope you get to enjoy your game.

    rg Allan

    Thursday, December 23, 2021 11:52 AM
  • This blog is great thank you.

    • Proposed as answer by Neareshop Thursday, April 21, 2022 7:18 AM
    Tuesday, December 28, 2021 7:02 AM
  • This is very appealing, however , it is very important.
    • Proposed as answer by Neareshop Thursday, April 21, 2022 7:21 AM
    Friday, April 1, 2022 6:11 AM
  • It could be because of the mods. Mods might be not properly configured, they might conflict with the game and make it crash.
    Friday, April 1, 2022 12:44 PM
  • I Love Your Post And You Also Welcome To My Site Thanks For Sharing.....<a href="">Love You</a>
    Wednesday, April 20, 2022 3:30 PM
  • Thank You For This <a href="">Amazing Software</a>
    Wednesday, April 20, 2022 3:30 PM
    Wednesday, April 20, 2022 3:31 PM
  • I really impressed with this because of some quality work and informative thoughts .
    Friday, April 22, 2022 6:47 AM
  • I just subscribe your site and want more info.. about it....
    Wednesday, May 4, 2022 12:24 PM
  • Steps To fix if folder keepsreverting to read-only on Windows -
    Change permissions
    Change the attributes

    1.Change permissions
    A lot of users have reported this problem. Because the majority of them confirmed that they solved it by changing the permissions, we suggest that you try this first.

    If you are the only user on the Windows 10 PC, do the following to change the permissions:

    Find your C Drive, right-click it and then choose Properties.
    A new window will appear. Click on Security tab.folder reverting to read only
    In the bottom right, click Advanced. Then click on Change permissions.change permissions folder read only
     Choose the user that’s of interest to you and then click Edit.
    Under Applies to: drop-menu, choose This folder, subfolders and files.
    Under Basic permissions check Full control and click OK.
    If there are more than one users on that computer, then follow these steps:

    Find your C Drive and double-click on it.
    You will see a Users folder. Double-click on it.users folder read only folder windows 10
    Now you should see your users folder. Right-click it and choose Proprieties.
    Go to the Security tab, and in the bottom-right click Advanced.folder changes to read only windows 10
    In the new window, in the bottom-left should see an Enable inheritance button. Click it.enable inheritance folder keeps reverting to read only
    After changing the permissions, the issue should be gone. If your still having problems, then go to the next solution.

    2. Change the attributes
    If a certain folder has the Read-only attribute, then a program can’t save files or make changes to it. To change the Read-only attribute to System by using the Attrib command in cmd, follow the steps:

    In the Windows search box type cmd. Right-click the result and choose Run as administrator.folder reverts to read only 
    To remove the Read-only attribute and to set the System attribute, type in the following command
    attrib -r +s drive:<path><foldername>
    Customize folders as some programs may not operate correctly with folders that have these attributes. To remove them, type
    attrib -r -s c:<foldername>
    Keep in mind that removing the Read-only or the System attribute of a folder can cause some customization loss, but it’s not particularly important unless you have something specific in mind.

    If you are still experiencing issues with permission opening files, this guide may help you fix the problem.

    We hope that these solutions worked for you, as many other Windows 10 users confirmed them.

    Don’t forget to leave any other questions you may have in the comments section below, and we’ll be sure to take a look.

    idee restoro Still having issues? Fix them with this tool:
    Download this PC Repair Tool rated Great on (download starts on this page).
    Click Start Scan to find Windows issues that could be causing PC problems.
    Click Repair All to fix issues with Patented Technologies

    This may help you,

    Ross Smith

    • Edited by rosssmith Wednesday, August 10, 2022 9:33 AM
    Wednesday, August 10, 2022 9:29 AM
  • this is usefull app
    Wednesday, August 17, 2022 8:06 AM