none
attachment error message in form RRS feed

  • Question

  • Hi

    I have two forms.  both have attachement fields assigned in the table.  One form will accept the attachments no problem.  the other form will not allow me to attach an item.  The manage attachments prompts to attach and I can go get the attachment but once it's in the box to attach, I select it and the message comes back No Current Record.  Why does this work on one form and not the other one?

    Please help 

    Tuesday, February 6, 2018 8:19 PM

All replies

  • Hi tsccat,

    You had mentioned that , You have 2 similar kind of Forms with attachment field.

    One is working and other is not working.

    Here, I want to confirm with you that is this Forms was also working correctly before and you got this issue now?

    If Yes, Most possible reason can be the corruption.

    To correct it, You can try to Comact and repair your database.

    Compact and repair a database

    If the issue is related with corruption then it will be corrected by Compact and repair.

    Are you using any VBA code to attach the file?

    Make sure you select any record first and then try to assign the attachment to it.

    If you created a new Form similar like other form and from starting you are facing the issue then maybe you did not follow the steps properly or some thing is incorrect or missing. This can be the reason for this form to not working correctly.

    Further, You can inform us and provide detailed steps how you create this form. What is your table design, sample code etc.

    We will try to reproduce the issue on our side and try to provide you suggestion to solve the issue.

    Reference:

    Attach files and graphics to the records in your database

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, February 7, 2018 5:37 AM
    Moderator
  • Hi tsccat,

    >> One form will accept the attachments no problem.  the other form will not allow me to attach an item.

    Based on your description, it seems there is something wrong in the other Form. Is the second Form bound or unbound? Did you set any data source for the second form?

    It would be helpful if you could share us your Access database, then we could work closely with you to reproduce your issue.

    Best Regards,

    Tao Zhou


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, February 8, 2018 8:17 AM
  • Whenever the topic of the attachment field type comes up - I feel obligated to point out that there are real draw backs to this field type.  I myself won't use them.

    This doesn't help in answering your question.  But if you are early into your design - and if you are going to have a lot of attachments - - and in particular if the file sizes might be large - - you instead should link to files that reside in a folder outside the database.

    Just an fyi post.....

    Thursday, February 8, 2018 10:02 PM
  • Hi tsccat,

    Is your issue solved?

    I find that you did not follow up this thread after posting the issue.

    If your issue is solved then I suggest you to post your solution and mark it as an answer.

    If your issue is still exist then try to refer the solution given by the community members.

    If then also you have any further questions then let us know about it.

    We will try to provide further suggestions to solve the issue.

    Thanks for your understanding.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, February 13, 2018 8:53 AM
    Moderator