none
SDV keeps reporting "Driver type is 'unknown' RRS feed

  • Question

  • Hi,

    SDV has been a great tool for us to find defects in the drivers.

    Recently, we noticed that the SDV is failing with the message

    "Driver type is 'Uknown'. This driver type is not supported by SDV.

    Please consult the documentation for supported driver type'

    We are using Visual Studio 2013, with WDK 8.1

    Windows 8.1 and Windows 7 64bit.

    It was working until about 1 month ago...

    The problem shows up in by either using the visual studio SDV GUI or the command line mode.

    I also tried to create a sample KMDF driver and SDV still does not run.

    I also tried to download the driver samples.

    The one I tried is:

    C:\Users\release\Desktop\Windows Driver Kit (WDK) 8.1 Samples\Sample KMDF Bus Driver for OSR USB-FX2\C++

    I also tried the new project:

    new->project->Kernel Mode Driver, USB(KMDF)

    I also tried the sample:

    C:\Users\release\Desktop\Windows Driver Kit (WDK) 8.1 Samples\SDV-FailDriver-KMDF\C++

    The SDV all fails with the same error.

    I am wondering what goes wrong?

    Thanks,

    Jason


    Monday, March 24, 2014 6:35 PM

Answers

  • Hi Jakob,

    SDV is running again after I uninstall Visual Studio 2010 on my Windows 8.1 PC.

    Thanks for pointing out how to identify this bug...but I hope this can be fixed....

    Thanks,

    Jason

    Monday, March 24, 2014 9:41 PM

All replies

  • Jason,

    I am glad SDV has been a great tool for you in the past.  Not so glad that you have the problem explained above.  Let us see if we can figure this out...

    I have a suspicion: Can you let me know exactly what version(s) of Visual Studio you have installed on your computer? Only Visual Studio 2013 or maybe also other versions? 

    I am asking as I am familiar with a bug in SDV that may manifest itself if you have multiple versions of Visual Studio installed.

    Thanks,

    - Jakob Lichtenberg

    Monday, March 24, 2014 8:51 PM
  • Hi Jakob,

    Thanks for the reply.

    Both machines that I tried are installed with multiple versions of Visual Studio.

    For the Windows 8.1 machine, I have Visual Studio 2010 and 2013 installed.

    For the Windows 7, I have Visual Studio 2005, 2010, 2013 installed.

    Your suspicion might be correct, and seems to make sense.

    The failed date for SDV is very close to the day which I installed Visual Studio 2010..!

    The last known working date is Feb 25, I installed VS 2010 around Feb 27, SDV found to fail on Mar 3.

    That being said, I do remember SDV was working on my Windows 7 machine before I setup the Windows 8.1 PC for dedicated testing.

    I plan to uninstall the 2010 on the Windows 8.1 PC, and also install VS2013 on a machine that is nearly fresh,

    to see if SDV is runable.

    I will keep you posted by what I found.

    Thanks,

    Jason

    Monday, March 24, 2014 9:17 PM
  • Hi Jakob,

    SDV is running again after I uninstall Visual Studio 2010 on my Windows 8.1 PC.

    Thanks for pointing out how to identify this bug...but I hope this can be fixed....

    Thanks,

    Jason

    Monday, March 24, 2014 9:41 PM