locked
Help [Microsoft JET Database Engine error '80004005] RRS feed

  • Question

  • User1225872194 posted

    Hi I've just reset my website up with a new company and currently getting an error that reads.

    Can anyone help me to resolve this please?

    Microsoft JET Database Engine error '80004005'

    Could not delete from specified tables.

    /include/dbConnOpen.asp, line 94

     

    Saturday, November 8, 2008 7:28 PM

Answers

  • User-1235926091 posted

    well I suppose there are two options.

    1) if it is a new installation, you can go to the developers and find out how to set it up in SQL Server
    2) if it is already populated with data, there is an SQL Migration Tool built into Access, however it doesn't do the best job migrating data.

    Your best bet is to poke around in the x-cart forums or contact tech support to see the best way to migrate.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, November 9, 2008 11:39 AM
  • User-821857111 posted

    Goes to show how much I know, thanks for the help on that, how do I update to an sql server?
     

    You don't need to.  The fact that the error message is from the Jet provider shows that the provider IS installed on the server.  Otherwise it couldn't raise the error.

    Have a look at this for help on the error message: http://support.microsoft.com/kb/240098, or go to http://groups.google.co.uk/group/microsoft.public.inetserver.asp.general?hl=en&lnk= for more help with classic ASP.


    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, November 9, 2008 12:12 PM

All replies

  • User-1235926091 posted

    For starters, you are in the asp.net forum and I am seeing that you are using classic asp.  So there are not a lot of people who can comfortably read your code above.

    Second.  If your new server happens to be 64bit, the Jet Driver is not likely to work.  consider updating your database to SQL Server, or at very least a .mdf database (runs on sql but sits in the local database directory like access.)

    Saturday, November 8, 2008 11:58 PM
  • User-1235926091 posted

    Two other observations regarding line 66... you should never post your sql password in a forum and you should never use the "sa" account when connecting to SQL Server.

    Sunday, November 9, 2008 12:04 AM
  • User-1235926091 posted

    Sorry I can't be of more help... maybe you can get more help here
    http://forum.x-cart.com/

    Sunday, November 9, 2008 12:05 AM
  • User1225872194 posted
    Goes to show how much I know, thanks for the help on that, how do I update to an sql server?
    Sunday, November 9, 2008 8:11 AM
  • User-1235926091 posted

    well I suppose there are two options.

    1) if it is a new installation, you can go to the developers and find out how to set it up in SQL Server
    2) if it is already populated with data, there is an SQL Migration Tool built into Access, however it doesn't do the best job migrating data.

    Your best bet is to poke around in the x-cart forums or contact tech support to see the best way to migrate.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, November 9, 2008 11:39 AM
  • User-821857111 posted

    Goes to show how much I know, thanks for the help on that, how do I update to an sql server?
     

    You don't need to.  The fact that the error message is from the Jet provider shows that the provider IS installed on the server.  Otherwise it couldn't raise the error.

    Have a look at this for help on the error message: http://support.microsoft.com/kb/240098, or go to http://groups.google.co.uk/group/microsoft.public.inetserver.asp.general?hl=en&lnk= for more help with classic ASP.


    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, November 9, 2008 12:12 PM
  • User1225872194 posted

    Thanks for you help guys,found the problem to be something to do with the database having a write protection disabled,

    Will look into the X-Cart forum as I have a long way to go before I can solve my problems.

    Tuesday, November 25, 2008 9:14 PM