locked
SharePoint Foundation 2013 - March 2016 CU Update RRS feed

  • Question

  • Hi,

    We have a SharePoint Foundation 2013 server (SQL separate) and we applied the last March 2016 CU Update to it.
    But the user that applied it, did not run the PSConfig tool immediately. I ran the PSConfig afterwards (like 12hours after the install). The server wasn't updated since a while. We reinstalled it last year with Service Pack 1 (15.0.4569.1506).

    We have a rather large list (45099 items) and we now have the problem that the dispforms and some other pages are having a slow page load (6 - 11 seconds).
    Everything seems to be running fine. CPU, Memory,... are the same like before the update.
    We checked the Distributed Cache and everything is healthy.
    We disabled search and checked if that did something to the performance, but it didn't change anything, so we re-enabled it.

    https://support.microsoft.com/en-us/kb/3114822

    I hope someone can give me a hint on where to look further.

    Thanks in advance.

    Kind regards,


    • Edited by SkylineS Thursday, March 31, 2016 10:13 AM
    Thursday, March 31, 2016 10:12 AM

Answers

  • Hi SkylineS,

    Please close the windows, add your site into IE Trusted Sites, then check "Launch the Developer Dashboard".

    Please do an IISRESET. After finishing, test again.

    In addition, as your list is very large, it may affect the page loading. For other pages that has this issue, check if there is much content or custom code in these pages.

    Thanks,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Victoria Xia Friday, April 8, 2016 8:35 AM
    • Marked as answer by Victoria Xia Monday, April 11, 2016 9:16 AM
    Wednesday, April 6, 2016 7:41 AM
  • Hi Wendy,

    We solved it. Our list had to much item security levels. We changed those, and everything works even faster than before.

    Every item had an unique security level. We now moved the items with the same security level to folders with the specific security and the items inherit their security from the folder. (We found this in the SharePoint best practice information).

    Thank you for all your help.

    Kind regards,

    • Marked as answer by SkylineS Tuesday, April 12, 2016 2:17 PM
    Tuesday, April 12, 2016 2:13 PM

All replies

  • Hi SkylineS,

    Please do an IISRESET. After finishing, test again, compare the result.

    If this issue still exists, please enable Developer Dashboard, and use the tool to check which may cause this issue.

    You can use the following PowerShell cmdlets to enable this feature:

    New-SPUsageApplication -Name "Health and Usage Application" -DatabaseName "SP2013_Health_and_Logging_Database"
    
    $svc = [Microsoft.SharePoint.Administration.SPWebService]::ContentService
    $dds = $svc.DeveloperDashboardSettings
    $dds.DisplayLevel = "On"
    $dds.Update()

    More information, please refer to:

    http://www.sharepoint-journey.com/developer-dashboard-in-sharepoint-2013.html

    Thanks,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, April 1, 2016 5:29 AM
  • Hi Wendy,

    Thank you for your help.

    After IISreset the issue is still the same.

    The Developer Dashboard is blank. The usage and health service is running and active. We never used that before, so I don't know if it worked before the update.

    When running New-SPUsageApplication it said that the database already existed.

    Is it a good idea to delete the service (with data) and recreate it? Maybe it's some authorization issue on the database.

    Kind regards,

    Friday, April 1, 2016 7:37 AM
  • Hi SkylineS,

    What did you mean that the Developer Dashboard is blank?

    Could you find the Developer Dashboard like the screenshot?

    If no, you don't need to delete the service application, just run the following cmdlets:

    $svc = [Microsoft.SharePoint.Administration.SPWebService]::ContentService
    $dds = $svc.DeveloperDashboardSettings
    $dds.DisplayLevel = "On"
    $dds.Update()

    Then launch the Developer Dashboard, and go to the problematic page, and select the request that you want to track.

    More information:

    http://www.sharepoint-journey.com/developer-dashboard-in-sharepoint-2013.html ("SQL queries running against each request" section)

    Thanks,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, April 4, 2016 1:31 AM
  • Hi Wendy,

    I ran the commands you gave me, and I found the button like you showed.

    When I clicked on it, I got this window:

    I can't upload images, so here is a link: http://nl.tinypic.com/r/sl7hj6/9

    Thank you for your help !

    Monday, April 4, 2016 6:23 AM
  • Hi SkylineS,

    Please close the windows, add your site into IE Trusted Sites, then check "Launch the Developer Dashboard".

    Please do an IISRESET. After finishing, test again.

    In addition, as your list is very large, it may affect the page loading. For other pages that has this issue, check if there is much content or custom code in these pages.

    Thanks,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Victoria Xia Friday, April 8, 2016 8:35 AM
    • Marked as answer by Victoria Xia Monday, April 11, 2016 9:16 AM
    Wednesday, April 6, 2016 7:41 AM
  • Hi Wendy,

    We solved it. Our list had to much item security levels. We changed those, and everything works even faster than before.

    Every item had an unique security level. We now moved the items with the same security level to folders with the specific security and the items inherit their security from the folder. (We found this in the SharePoint best practice information).

    Thank you for all your help.

    Kind regards,

    • Marked as answer by SkylineS Tuesday, April 12, 2016 2:17 PM
    Tuesday, April 12, 2016 2:13 PM