none
Auto list members is active even when disabled.

    Question

  • Even in a "text file" when a character is typed a list pops up.

    How do I prevent this?

    Tuesday, January 17, 2017 12:39 AM

Answers

  • Thank you for your response.
    The file was named "text.inc".
    .inc was the file extension I've used since '93 but the unwanted "List Members" started with VS2015.
    Each item in the list has an icon of a box with "<g class="gr_ gr_21 gr-alert gr_spell gr_disable_anim_appear ContextualSpelling ins-del multiReplace" data-gr-id="21" id="21">abc</g>" in it. I suspect that that makes it HTML?.
    I tried turning off "Auto List Members" but no effect. Tried exporting settings and
    "Auto list members is still set. I tried editing the settings file and importing it again and still
    no effect. The properties listed it as "C/C++ header". This does not affect the "List Members".
     I set it to "Text" and this had no effect.
    I renamed all my ".inc" files to ".ash" and that did the trick.
    Thanks.

    • Marked as answer by Steve Tulloh Thursday, January 19, 2017 11:47 PM
    Thursday, January 19, 2017 11:47 PM
  • Thank you for your response.
    I tried /safemode and that had no effect but thanks for the tip about /safemode
    I might have use for it in the future.
    • Marked as answer by Steve Tulloh Thursday, January 19, 2017 11:49 PM
    Thursday, January 19, 2017 11:49 PM

All replies

  • Maybe it is not a text file, but something like TextFile.txt.vb, for example, which is interpreted as a code file. When you create a new text using Add New Item wizard, make sure to select a Text File type from the list.

    Or give more details about the problem.

    Tuesday, January 17, 2017 5:59 AM
  • Hi Steve Tulloh,

    >> Auto list members is active even when disabled

    Do you mean that the auto list still shows up after clearing the checkbox of “Auto list members”?

    I just turned it off by the following steps:

    Tools -> options -> Text Editor-> All languages -> General -> Auto list members

    The auto list members do not pop up again.

    But, no matter I turn on or off the auto list members, it just does not pop up in the text file.

    Not sure if this is caused by third-party extensions with its own IntelliSense you could run your VS in safe mode to have a check.

    Please refer to the command line:   Devenv /safe

    You may also try to reset the setting in your VS, Tools -> options-> import and export settings-> reset all settings.

    Could you please share us more details about it?  And please make sure it’s the real text file type but the text file with other language suffix. Please feel free to let me if I misunderstood you.

    Best regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, January 17, 2017 8:16 AM
  • Hi Steve, 

    If there is a reply help  to resolve your doubts, please help to mark it as answer which would be helpful to others who have the same issue as yours.  And feel free to let me know if your have any other issue.

    Thanks for your understanding and cooperation:)

    Best regards,

    Fletcher 


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, January 19, 2017 12:43 PM
  • Thank you for your response.
    The file was named "text.inc".
    .inc was the file extension I've used since '93 but the unwanted "List Members" started with VS2015.
    Each item in the list has an icon of a box with "<g class="gr_ gr_21 gr-alert gr_spell gr_disable_anim_appear ContextualSpelling ins-del multiReplace" data-gr-id="21" id="21">abc</g>" in it. I suspect that that makes it HTML?.
    I tried turning off "Auto List Members" but no effect. Tried exporting settings and
    "Auto list members is still set. I tried editing the settings file and importing it again and still
    no effect. The properties listed it as "C/C++ header". This does not affect the "List Members".
     I set it to "Text" and this had no effect.
    I renamed all my ".inc" files to ".ash" and that did the trick.
    Thanks.

    • Marked as answer by Steve Tulloh Thursday, January 19, 2017 11:47 PM
    Thursday, January 19, 2017 11:47 PM
  • Thank you for your response.
    I tried /safemode and that had no effect but thanks for the tip about /safemode
    I might have use for it in the future.
    • Marked as answer by Steve Tulloh Thursday, January 19, 2017 11:49 PM
    Thursday, January 19, 2017 11:49 PM
  • Hello Fletcher,

    Now I'm not sure what "Mark as Answer" I was hoping that it gives credit for the work involved

    in submitting a reply. I hope it does not steer others to misconceive that the problem was actually

    resolved. I needed a "Mark as AN Answer" or some such.

    Thursday, January 19, 2017 11:54 PM
  • Hi Steve,

    I really appreciate your understanding, and we'll keep looking into this issue.

    I'm still trying to repro it in my side.

    I noticed that you exported settings, and did you try to reset all settings? Not sure if that could fix it, but it's worth trying. And thanks for your cooperation:)

    Best regards,

    Fletcher 


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, January 20, 2017 11:08 AM
  • Hello Fletcher,

    Thanks, I tried resetting the settings, I also tried reinstalling:

    Microsoft Visual Studio Professional 2015
    Version 14.0.25431.01 Update 3
    Microsoft .NET Framework
    Version 4.6.01055

    Installed Version: Professional

    I also had 2013 and 2017 installed but 2017 trial ran out so I uninstalled them both.

    BTW this is an Assembly language project.

    Thank you for your efforts.

    Steve <g class="gr_ gr_170 gr-alert gr_spell gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="170" id="170">Tulloh</g>


    Friday, January 20, 2017 9:54 PM