none
Azure Sphere is able to connect to wifi RRS feed

  • Question

  • I was in a hotel environment and there is a lot wifi SSID around (37 according to wifi scan result).

    When I run w"azsphere device wifi scan", it not even be able to discover those two SSID.

    I added them directly using "azsphere device wifi add", sphere is not able to connect to them either. But both works fine with my laptop.

    Is there any wifi limitation that cause Azure Sphere not able to handle many SSID environment?


     

    Wednesday, August 28, 2019 6:16 PM

All replies

  • Hi Shaoshan Fan What is the error message you see when trying to connect. Also do you get any message after running azphere device wifi scan?

    If you encounter Wi-Fi problems, first ensure that your Wi-Fi network uses 802.11b/g/n; Azure Sphere devices do not support 802.11a.

    The command wifi scan will return up to 64 wireless network, but the number of wireless networks displayed may be limited by environmental factors such as the density of access points in range

    https://docs.microsoft.com/en-us/azure-sphere/reference/azsphere-device#wifi-scan


    Thursday, August 29, 2019 12:51 AM
    Owner
  • There is no error message.

    "azsphere device wifi scan" list 37 SSID, but not include mine hotspot.

    I added them directly with "azsphere device wifi add", but it always showing as disconnected and status showing as "SCANNING", behavior like this SSID not exist.

    Also, the same hotspot with same setup works correctly in not crowd wifi environment.

    Friday, August 30, 2019 6:35 PM
  • I am stuck at this same issue. Wifi added but disconnected and scanning. Not sure what's up with it.

    Edit: I could not find my wifi network with command wifi list. Looks like this device only supports wifi band 5.0 ghz? I must have missed this somehwere. So right I can only connect this device to internet with my phone hotspot as my home router is 2.4ghz. Come on!!

    Friday, August 30, 2019 9:29 PM
  • I have the exact same issue and haven't found anything to resolve the issue. I have a router that is 802.11 b/g/n and supports both 2.4/5 GHz. I ensured that the device was connected to the 5GHz network and didn't saw any changes. Below are the commands that I tried to run:

    >azsphere device wifi add --ssid Panomaric_network --key ****
    Add network succeeded:
    ID                  : 0
    SSID                : Panomaric_network
    Configuration state : enabled
    Connection state    : unknown
    Security state      : psk
    
    Command completed successfully in 00:00:01.8593129.
    
    >azsphere device wifi show-status
    SSID                :
    Configuration state : unknown
    Connection state    : disconnected
    Security state      : unknown
    Frequency           :
    Mode                :
    Key management      : UNKNOWN
    WPA State           : SCANNING
    IP Address          :
    MAC Address         : 00:02:b5:03:4f:c1

    Obviously in the key part I put the correct one. I also, connect it to my mobile hotspot but same issue appeared. Any thoughts? 

    P.D: The device is an AVNET MT3620

    Wednesday, September 11, 2019 1:54 AM
  • Ok, so I didn't give up trying and decided to do the "Avnet Azure Sphere Starter-Kit: Advanced Tutorial" by peterfenn. The first part of the tutorial doesn't require wifi but it verifies the status of all the sensors including the wifi. After successfully uploading the project and running it, the device was able to connect to the wifi. Below is the output results:

    Remote debugging from host 192.168.35.1
    Version String: Avnet-Starter-Kit-reference-V1.0
    Avnet Starter Kit Simple Reference Application starting.
    LSM6DSO Found!
    LPS22HH Found!
    LSM6DSO: Calibrating angular rate . . .
    LSM6DSO: Please make sure the device is stationary.
    LSM6DSO: Calibrating angular rate complete!
    Opening Starter Kit Button A as input.
    Opening Starter Kit Button B as input.
    SSID: Panoramic_network
    Frequency: 5785MHz
    bssid: 70:03:7e:fe:71:0f
    
    LSM6DSO: Acceleration [mg]  : -0.1220, 0.1220, 18.7880
    LSM6DSO: Angular rate [dps] : -0.07, 0.00, 0.00
    LSM6DSO: Temperature  [degC]: 35.09
    LPS22HH: Pressure     [hPa] : 1014.67
    LPS22HH: Temperature  [degC]: 33.57
    
    
    

    I re-verify the results of the wifi connectivity by running the following command:

    C:\Users\Arnaldy\Documents>azsphere device wifi show-status
    SSID                : Panoramic_network
    Configuration state : enabled
    Connection state    : connected
    Security state      : psk
    Frequency           : 5785
    Mode                : station
    Key management      : WPA2-PSK
    WPA State           : COMPLETED
    IP Address          : 192.168.0.136
    MAC Address         : 00:02:b5:03:4f:c1
    
    Command completed successfully in 00:00:01.6234109.
    
    C:\Users\Arnaldy\Documents>

    The link for the tutorial is: Avnet Azure Sphere Starter-Kit: Advanced Tutorial

    Hope it works for you guys.

    Also, keep in mind that these devices only accept 5GHz network.

    6.2.5
    • Proposed as answer by Arnaldy Medina Sunday, September 15, 2019 7:11 PM
    Sunday, September 15, 2019 7:10 PM