locked
Error while deleting publication RRS feed

  • Question

  • I am trying to delete a test publication which I created on a database and I am getting the following error

    I am on SQL Server 2008 R2, running Windows 2008 R2. Have right clicked on SSMS and said "run as administator to start it. currently logged in as the same ID which the error message says cannot be found (or is not able to get information about.

     

    Monday, March 7, 2011 8:10 AM

Answers

  • Hi,

    It sounds to me that this domain account cannot be varified by the activity directory service (ADS), please double check whether the ADS is properly running. As a work around, you may try a local Windows account or SQL login account who is at least db_owner in the publication database. As SevenKnights said, please check the SQL Server Error Log as well.


    Best Regards,
    Chunsong Feng

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by WeiLin Qiao Monday, March 14, 2011 10:04 AM
    Tuesday, March 8, 2011 6:22 AM

All replies

  • Hi,

    It seems like account with which you logged in (ie in this case The account which is shown in error), does not have access for the publication.

    Check whether the login is available in PAL (publication access list)

    Try to delete the publication using an account which is a part of the PAL.

    REgards

    Ashwin

    Monday, March 7, 2011 8:14 AM
  • the account which I am logged on with is a member of sysadmin group of SQL. I will still go and check the PAL.
    Monday, March 7, 2011 1:58 PM
  • I am getting this error when I am trying to access the Publication Access List

     

    Monday, March 7, 2011 2:17 PM
  • The error is about your current user '<computer>\user1' right? not <computer>\Administrator ?

     

    To be honest, you dont really need run SSMS under Admin, you can just add yourself in SQL server to have SA. and delete publication from there. I think the publication/subscription wizards running separately from SSMS.


    If you think my suggestion is useful, please rate it as helpful.
    If it has helped you to resolve the problem, please Mark it as Answer.

    Sevengiants.com
    Monday, March 7, 2011 2:17 PM
  • domain\user

     

    here the user is a member of the sysadmin group (or role).

    Monday, March 7, 2011 2:19 PM
  • domain\user

     

    here the user is a member of the sysadmin group (or role).

    can you check your ERRORLOG file to see any abnormal errors? Sounds like authentication problem. Would you be able to try to use SA account or another SQL auth account with sysadmin?

    If you think my suggestion is useful, please rate it as helpful.
    If it has helped you to resolve the problem, please Mark it as Answer.

    Sevengiants.com
    Monday, March 7, 2011 2:35 PM
  • hi,

    can you try xp_logininfo 'your_login_name'

    If you have enabled SQL Server authentication, can you try to connect using an sa user and then try the same?

    regards

    Ashwin Menon


    Regards, Ashwin Menon My Blog -> sqllearnings.wordpress.com
    Monday, March 7, 2011 2:35 PM
  • Here is the output of the xp_logininfo SP

    Msg 15404, Level 16, State 19, Procedure xp_logininfo, Line 62
    Could not obtain information about Windows NT group/user 'domain\user', error code 0x5.

     

    I have enabled SQL Auth, and I get a whole lot of errors around security when I try to setup replication via that way.

     

    I have a feeling that I won't be the first one to say that SQL replication is a nightmare when it comes to setting up accounts and managing security.

    Tuesday, March 8, 2011 6:15 AM
  • Hi,

    It sounds to me that this domain account cannot be varified by the activity directory service (ADS), please double check whether the ADS is properly running. As a work around, you may try a local Windows account or SQL login account who is at least db_owner in the publication database. As SevenKnights said, please check the SQL Server Error Log as well.


    Best Regards,
    Chunsong Feng

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by WeiLin Qiao Monday, March 14, 2011 10:04 AM
    Tuesday, March 8, 2011 6:22 AM