locked
Server problem maybe RRS feed

  • Question

  • I purchased a new computer with windows 8 on it. I installed my

    Visual Studio 2008 and using the Visual Basic 2008 from Visual Studio.

    I used Server Explorer to create a new database and entered in

    Server Name box .\SQLEXPRESS and got an error. This is what Works

    on my old computer with windows 8 o it, and the computer name is JERE

    how do I find out the new server name is for the new computer

    Here is the error message.

    A network-related or instance-specific error occurred while establishing

    a connection to SQL server. The server was not found or was not

    accessible. Verify that the instance name is correct and that

    SQL Server is configured to allow remote connections.

    (provider: Named pipes Provider, error: 40 – Could not open

    connection to SQL Server)

    JereBear



    Jere Small

    Sunday, April 21, 2013 6:44 AM

Answers

  • Okay, I went to Tools then Connedct to server it asked for my computer name. then I went to tools again and used connect to database and selected Microsoft SQL Server Database File then searched for my .mdf databse that I already had and seled it and it loaded ok.  It gave the data source as  (LocalDB)\v11.0. That's it, I was able to use the server explorer to create a new database using (LocalDB)\11.0, exactly like it is, weird but that's it.

    Data Source=(LocalDB)\v11.0;AttachDbFilename="C:\Users\Jere\Documents\

    Baseball2013\Bigger Leaguer Baseballer\Baseball2012.mdf";Integrated

    Security=True;Connect Timeout=30

    Thanks JereBear


    Jere Small


    Jere Small

    • Marked as answer by JereTheBear Tuesday, April 23, 2013 2:34 PM
    Tuesday, April 23, 2013 2:34 PM

All replies

  • and entered in Server Name box .\SQLEXPRESS and got an error. This is what Works on my old computer with windows 8 o it, and the computer name is JERE how do I find out the new server name is for the new Computer

    Hello Jere,

    If the SQL Server Express is installed with the Default Settings, then this is the same Name .\SQLEXPRESS you have to use.

    Please check if the Services "SQL Server (SQLEXPRESS)" and "SQL Server-Browser" are running. Can you connect to SQL Server using SSMS (with the same Server Name)?


    Olaf Helper

    Blog Xing


    Sunday, April 21, 2013 7:08 AM
  • I don't know how do any of that checking. check if running or the SSMS thing.  How Can I get the server name.

    The server I used before was sql server 2005 now I am using server 2008. is their a command line command like hostname it returns the computer name, is there on like that for the server name.

    Please check if the Services "SQL Server (SQLEXPRESS)" and "SQL Server-Browser" are running. Can you connect to SQL Server using SSMS (with the same Server Name)?

    JereBear


    Jere Small

    Sunday, April 21, 2013 7:33 AM
  • You can check the Services with Start menu => Run => Service.msc; the Windows Service Manager.

    Olaf Helper

    Blog Xing

    Sunday, April 21, 2013 7:36 AM
  • Hello,

    If you connect to the SQL Server instance locally, please use .\(instancename) or localhost\(instancename).By default, the instance name is SQLEXPRESS. If you install named instance, please refer to the suggestion as Olaf post above to find the instance name.
    If you want to find the local computer name, open command prompt window, type "hostname".

    Regards,
    Fanny Liu


    Fanny Liu
    TechNet Community Support

    Monday, April 22, 2013 7:16 AM
  • Okay, I went to Tools then Connedct to server it asked for my computer name. then I went to tools again and used connect to database and selected Microsoft SQL Server Database File then searched for my .mdf databse that I already had and seled it and it loaded ok.  It gave the data source as  (LocalDB)\v11.0. That's it, I was able to use the server explorer to create a new database using (LocalDB)\11.0, exactly like it is, weird but that's it.

    Data Source=(LocalDB)\v11.0;AttachDbFilename="C:\Users\Jere\Documents\

    Baseball2013\Bigger Leaguer Baseballer\Baseball2012.mdf";Integrated

    Security=True;Connect Timeout=30

    Thanks JereBear


    Jere Small


    Jere Small

    • Marked as answer by JereTheBear Tuesday, April 23, 2013 2:34 PM
    Tuesday, April 23, 2013 2:34 PM