none
SDL Threat Modelling Tool installation issues RRS feed

  • Question

  • I'm having troubles installing the SDL Threat Modelling Tool. I've downloaded the installer from here (http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=2955), and also installed the Visio 2010 60 day trial (as per installation instructions). However, I'm getting the following message box upon trying to install the modelling tool: "Microsoft Office Visio must be installed prior to the installation of the SDL Threat Modeling Tool. Would you like to navigate to the Visio web site?". Clicking "Yes" takes me to the Visio website and halts the install. Clicking "No" halts the install.

    Visio is definitely installed, however the tool installer isn't finding it. Running Windows 7, and 32-bit Visio is installed (under Program Files (x86)).

    Any help is much appreciated. Thank you.

    Tuesday, April 24, 2012 11:42 AM

Answers

  • I tried installing on my Win XP machine, and had better luck with that. I'm going to move forward with that install for my purposes. Thanks for your assistance.
    • Marked as answer by cboers Thursday, April 26, 2012 2:37 PM
    Thursday, April 26, 2012 2:37 PM

All replies

  • What's the path of VISIO.EXE on your system? If you have it installed in a non-default location, then create a placeholder VISIO.EXE file (anything inside):

    For x86 office system on x64 box: C:\Program Files (x86)\Microsoft Office\Office14\VISIO.EXE

    For all other setups: C:\Program Files\Microsoft Office\Office14\VISIO.EXE

    HTH,

    Adel.

    Wednesday, April 25, 2012 3:34 PM
  • The path on my machine is: C:\Program Files (x86)\Microsoft Office\Office14\VISIO.EXE

    I tried creating placeholders at: C:\Program Files\Microsoft Office\Office14\VISIO.EXE and C:\Program Files (x86)\Microsoft Office\Office12\VISIO.EXE

    But still no luck. The installer is still telling me Visio needs to be installed.

    Carel

    Wednesday, April 25, 2012 4:39 PM
  • Could you attach a screenshot of the installer window and the error message?

    Wednesday, April 25, 2012 5:00 PM
  • Wednesday, April 25, 2012 5:12 PM
  • I tried installing on my Win XP machine, and had better luck with that. I'm going to move forward with that install for my purposes. Thanks for your assistance.
    • Marked as answer by cboers Thursday, April 26, 2012 2:37 PM
    Thursday, April 26, 2012 2:37 PM
  • Adel,

    So is it ok if I delete the placeholder file after installation of SDL tool? Also I hope an internal bug has been raised to rectify this issue :)

    Thanks,

    CPPShark

    Wednesday, December 12, 2012 8:23 AM