locked
Using IIS outside of VWD express 2008? RRS feed

  • Question

  • User250266592 posted

    Hi,

    Just trying to get into ASP.net, so installed Visual Web Developer 2008 Express Edition. However I also want to build some basic pages outside of VWD just using notepad and IIS etc as this is how one of my books starts, and I like the idea of starting there to get my head around some basic priciples etc.

    I have IIS 6.0 working ok displaying my HTML pages, but when I try a basic aspx page I get the error:

    HTTP Error 404.3 - Not Found
    The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

    I presume this is because the ASP complier / runtime isnt installed / configured into IIS? Am I right in thinking VWD Express doesnt actually utilise IIS but rather its own inbuilt server?

    If so does IIS just need to be configured somehow to handle ASP based on whats installed as parts of VWD, or do I need to install (the rather large) .net 3.5 SDK 2008 so as to be able to work with ASP and IIS outside of VWD? If so whats the difference between that SDK, and whatever SDK etc comes as part of VWD Express?

    Sorry for lots of newbie type questions, I have tried researching online but this is as far I can can figure it out, and I really like to understand how it works / whats going on, and to get a clean installation. 

    Many thanks!

     Anthony

    Thursday, February 26, 2009 1:13 PM

Answers

  • User-1028151323 posted

     You need to install the .Net framework, if you view properties on your site you should see a ASP.Net tab and then you can select the framework version. Keep in mind it only shows versions 1 & 2 even with 3.5 installed because 3.5 is just add-ons to the 2.0 base framework.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, February 27, 2009 7:42 AM