none
Mails are coming back to Outbox after logging again to Outlook. RRS feed

  • Question

  • We have an Add-in to Outlook which is connector to our back end mail servers.

    Sometimes mails are coming to Outbox after logging again to Outlook.  Recipient is receiving the mails and also I can see the mail sent folded as well, but the problem is mails are coming back to Outbox after re logging to Outlook. 

    I am using IMAPISupport interface to move mails from Outbox to Sent  items. Any idea why mails are coming back outbox after re login even though mails are delivered to recipients and I can see a mail copy of same mail in send item as well.

    --Anil


    ~Mahesh~

    Friday, August 23, 2013 5:53 AM

All replies

  • If this issue happened sometimes, it seems the code might be fine and the mail was unsent by

    some reasons.

    Please look at Messages are stuck in the Outbox to find the reason.

    Also, you might need to reproduce this issue and debug your add-in to find the reason.




    • Edited by Andy_mic Friday, August 23, 2013 5:57 PM
    Friday, August 23, 2013 5:51 PM
  • Hi,

    Mails aren't stuck in Outbox,  when mail is sent, mail is getting moved to sent items from Outbox, mail is cleared from Outbox. But when I re start Outlook for some reason mail is coming back to Outbox, now same mail is there in both Outbox and Sent item and mail is delivered to all the recipients.  

    Yes, I have debugged and I don't see any issue. We are using IMAPISupport::CopyMessages functions to copy mails from Outbox to Sent item.  IMAPISupport::CopyMessages is returning S_OK when message is copied. 




    ~Mahesh~

    Saturday, August 24, 2013 6:31 AM