locked
Web service failed to publish RRS feed

  • Question

  •  

    hi everyone

     

    i am not sure if i am posting in the right section by i need help with my problem

     

    i wrote some web service in C# with Visual studio 2005

     

    those web service are already posted on the server, but i did some changes to the web services and when i try to republish them on the same server Visual studio tells me at the bottom "publish failed".

    and i dont know more then that, i dont know were to look for some more informattion on why Visual studio failed to publish my web services.

     

     

    Ok i got some info on why it failed to publish: so far it tells me :

    Unable to create the Web 'http://10.20.20.103:90/WSTraitex'. The Web server does not appear to have the FrontPage server extensions installed.

    Error: Unable to create the Web 'http://10.20.20.103:90/WSTraitex'. The Web server does not appear to have the FrontPage server extensions installed.

     

    anybody know what that is?

    by the way i also have Sharpoint 2007 installed on that server, mybe its because of SP 2007 i dont know....

     

    Does anybody know how to configure IIS 6.0 so i can tell VS 2005 that FPSE is installed...

    please some one must know a way to get that fixed i am sur i am not the first one struggeling with IIS......

     

    thanks guys

    Thursday, July 26, 2007 8:56 AM

Answers

  • There is no magic in publishing of web services. Just copy the files from the bin directory over and don't use the publish option.
    Wednesday, August 8, 2007 12:13 AM
    Moderator
  • Probably your admin did some configuration changes on the server so he removed FP extensions for security reasons. FP are used by Visual Studio to upload files in the publish process.
    SharePoint can be a problem if it's installed on the same port as your service was.
    So better ask your admin what to do, to upload the files using FTP or some other way as OmegaMan write.

    Wednesday, August 8, 2007 12:28 AM

All replies

  • There is no magic in publishing of web services. Just copy the files from the bin directory over and don't use the publish option.
    Wednesday, August 8, 2007 12:13 AM
    Moderator
  • Probably your admin did some configuration changes on the server so he removed FP extensions for security reasons. FP are used by Visual Studio to upload files in the publish process.
    SharePoint can be a problem if it's installed on the same port as your service was.
    So better ask your admin what to do, to upload the files using FTP or some other way as OmegaMan write.

    Wednesday, August 8, 2007 12:28 AM
  •  

    Just put the execution rights to scripts and executables to the _vti_bin directory of your website. Use IIS manager to do that task. Right click on _vti_bin, properties, virtual directory... in "execution rights" select "scripts and executables". thats all. (its assumed that you have installed FP extensions...)
    Thursday, October 25, 2007 8:18 PM