locked
Unable to add components to windows forms in VS 2011

    Question


  • I am getting this when I try to add a component to windows form.I tried debugging restarting and everything even if I create a new project this is what I am getting. Please help me.

    Jithu R Jacob


    • Edited by Jithu R Tuesday, May 08, 2012 3:21 AM
    • Moved by Bob_Bao Wednesday, May 09, 2012 2:59 AM (From:Visual Basic Express Edition)
    Tuesday, May 08, 2012 3:18 AM

All replies

  • Be aware it is a beta version, so this can be a bug, this is the bug website from Microsoft

    http://connect.microsoft.com


    Success
    Cor

    Tuesday, May 08, 2012 7:22 AM
  • Are you using windows 8 ?

    Thanks, Nishanth Mohan

    Tuesday, May 08, 2012 12:52 PM
  • Yes I am using Windows 8 . I have already submitted this report but still no reply from microsoft officials.

    Jithu R Jacob

    Thursday, May 10, 2012 5:06 AM
  • Hi Jithu,

    we believe this is fixed in the upcoming RC build of Visual Studio.  To get you up and running in the meantime, it might be related to some permission issues.  Could you download procmon from http://technet.microsoft.com/en-us/sysinternals/bb896645.  Go to file | Capture Events to turn off logging.  Right before you add a control to the XAML form go back to capture events.  Once you get the error, turn capture events back off to try to limit the output.  Send the procmon log to mikewong at microsoft.com so I can help interpret the results.  That will tell us if it is similar a bug that has been fixed in RC.

    thanks!

    mike

    • Marked as answer by Bob_Bao Tuesday, June 12, 2012 6:11 AM
    • Unmarked as answer by Jithu R Tuesday, June 26, 2012 6:47 AM
    Thursday, May 17, 2012 11:52 PM
    Moderator
  • Hi,

    I am using Windows 8 Consumer Preview and VS11 Ultimate with .net 4.5 and faced the same issue.

    The other way round is to create controls in VS2010 WPF application and copy paste them in VS11 XAML editor.

    Caution: Not all the controls of WPF can be used in VS11 like label.

    Kazim

    Saturday, May 19, 2012 3:51 PM
  • Same exact problem here. Windows 8 consumer preview upgraded from from windows 7 machine with VS2011 express beta for Windows 8. Various flavors of uninstall/reinstalling don't appear to have any effect.
    Sunday, May 20, 2012 8:33 PM
  • I am also having the same problem.  I can manipulate controls from samples, but I cannot add any controls either to the sample or to a new project.
    Saturday, May 26, 2012 5:02 PM