locked
Simulator causing problems with my keyboard

    Question

  • I have a Microsoft Natural Ergonomic Keyboard 4000, and I have programmed all of the "favorite" keys along the top to open various apps. Among these I have the "Search" button set to launch www.bing.com, and the "Mail" button set to launch Thunderbird.

    After invoking the Simulator (and it took quite some time to work out that this was the cause of the problem), my keyboard drivers seem to get in a state of confusion and all of these programmed button functions are ignored. The "Search" button always opens the Search pane within the Start menu, and the "Mail" button always attempts to launch Outlook. (Note that this is happening on my physical PC, not inside the Simulator itself.)

    I've tried this with both the old IntellitypePro drivers and also with the newer Mouse and Keyboard Center. With the former, I find that if I log out, launch the keyboard config window, select to choose a different keyboard, and then click OK with the Ergonomic Keyboard 4000 still selected, it will revert back to the required behaviour until I next use the Simulator. With the Mouse and Keyboard Center, a second keyboard has mysteriously appeared within its configuration window and becomes active, and no matter what I try I cannot remove it or get this configuration to switch back to the Ergonomic Keyboard 4000.

    This is driving me slightly insane. Is anyone else seeing similar problems?


    Adam -- My new book, "Windows Phone 7 Game Development" is out now! See http://www.adamdawes.com/books/wp7gamedev.html for more details.

    Sunday, September 30, 2012 9:30 PM