none
Active Sync not getting connected RRS feed

  • Question

  • I'm using AM335x Beagle Bone black with WinCE 7 BSP VS 2008 on a Windows 7 PC. I'm using Mobile Device Centre. When the device boots, I'm getting '**USB device not recognized**' pop-up message. I have checked the following.

    1. Required catalog items have been added
    2. All the USB drivers are in final image
    3. Tested it in windows XP 32-bit PC - error persists
    4. All the USB drivers are getting loaded
    5. Checked for mobile device-based updates in PC

    The catalog items I have added are,

    1. Core OS\Windows Embedded Compact\Device Drivers\USB\USB Function\USB
    Function Clients\USBFN Serial Client
    2. Core OS\Windows Embedded Compact\Device Drivers\USB\USB Function\USB
    Function Support
    3. Core OS\Windows Embedded Compact\Applications - End User\Active
    Sync\File Sync
    4. Core OS\Windows Embedded Compact\Applications - End User\Active Sync
    5. Core OS\Windows Embedded Compact\Shell and User
    Interface\Shell\Graphical Shell\Standard Shell
    6. Third Party\BSP\AM33X_BSP\ARMV7\Drivers\MUSB OTG Driver

    Am I missing any catalog item? What else can I verify for ActiveSync connection?

    The registry values in the final image NK.bin include

    [HKEY_LOCAL_MACHINE\Drivers\USB\FunctionDrivers]

    "DefaultClientDriver"="Serial_Class"

    [HKEY_LOCAL_MACHINE\Drivers\USB\FunctionDrivers\Serial_Class]

    "idVendor"=dword:045E

    "idProduct"=dword:00ce

    "Manufacturer"="Texas Instruments"

    "Product"="AM33x"

    "DevConfig"=hex:10,00,00,00,78,00,00,00,00,01,00,00,00,4e,00,00,00,00,08,00,00,00,00,00,00

    "Index"=dword:5

    [HKEY_LOCAL_MACHINE\Drivers\USB\FunctionDrivers\Serial_Class\Config]

    "EnableFlowHard"=dword:0

    "EnableFlowSoft"=dword:0

     I'm building my BSP in debug mode only. So, when I observed the logs, I found that serialusbfn.dll is not getting loaded. How to get it loaded?

    Thanks

    Wednesday, January 15, 2014 9:53 AM

Answers

  • Hi GSR,

    It's now working in both Windows 7 and Windows XP. 

    Previously I was building the BSP in Debug mode. I changed it to Release mode now.

    I ensured that KITL is disabled in OS Design and disabled KITL in eboot also when the device boots.

    In Windows XP, it gets connected just like that.

    In Windows 7, Windows update detected the device and installed drivers for it. It didn't get connected the first time (or maybe I didn't wait for few more minutes). The second time also Windows update installed drivers and got connected. From then, its getting connected every time in 2 minutes. No installation of drivers after that. 

    I think, due to some timing issues, Active Sync is not getting connected in Debug mode.

    Thanks,

    6G



    • Marked as answer by 6G Thursday, January 16, 2014 11:24 AM
    • Edited by 6G Thursday, January 16, 2014 11:28 AM
    Thursday, January 16, 2014 6:49 AM

All replies

  • Hi 6G,

    I don't know what is our OSDesign Configuration.

    But, we faced similar problem with WINCE7+ BeagleBone Black + Active Sync.

    The difference between yours and our observations is that, in our case it worked on Windows XP machine.

    Thank You & Regards,

    GSR

    Wednesday, January 15, 2014 5:51 PM
  • Hi GSR,

    It's now working in both Windows 7 and Windows XP. 

    Previously I was building the BSP in Debug mode. I changed it to Release mode now.

    I ensured that KITL is disabled in OS Design and disabled KITL in eboot also when the device boots.

    In Windows XP, it gets connected just like that.

    In Windows 7, Windows update detected the device and installed drivers for it. It didn't get connected the first time (or maybe I didn't wait for few more minutes). The second time also Windows update installed drivers and got connected. From then, its getting connected every time in 2 minutes. No installation of drivers after that. 

    I think, due to some timing issues, Active Sync is not getting connected in Debug mode.

    Thanks,

    6G



    • Marked as answer by 6G Thursday, January 16, 2014 11:24 AM
    • Edited by 6G Thursday, January 16, 2014 11:28 AM
    Thursday, January 16, 2014 6:49 AM