locked
JBOSS 6.0.0 in Azure RRS feed

  • Question

  • Hi! I am trying to install a JBOSS 6.0.0 server in an Azure platform. I am using a hosted service where I copy jboss6.0.0 and jdk1.6.

    Finally I start JBOSS with the command

    jdk1.6.0_21\bin\java `-Djava.endorsed.dirs=$location\jboss-6.0.0\lib\endorsed `-jar jboss-6.0.0\bin\run.jar start-domain

    And when I connect to the remote desktop and connect to http://localhost:8080 jboss welcome page appears. but when I try to connect through my computer with the assigned URL like:

    http://b2018e270f4a47ab8cac0849e826768b.cloudapp.net:8080/

    nothing appears....

    Does anyone know what I am missing? Could any of you help me? I would appreciate any help.

    Thank you in advance.


    Thursday, August 11, 2011 2:48 PM

Answers

  • Hi Mapiruli,

    To expose the service to outside of Windows Azure, we need to define an input endpoint for the role. An input endpoint will enable load balancer to route requests to role instances. Have you done this step in ServiceDefinition.csdef file?

        <Endpoints>
          <InputEndpoint name="WorkerIn" protocol="tcp" port="8080" localPort="8080" />
        </Endpoints>

    If it still does not work, please also consider it as an firewall issue. If so, you may consider adding a firewall rule via startup task:

    netsh advfirewall firewall add rule name="YourRuleName" dir=in action=allow protocol=TCP localport=<yourport>

    Resources: Internal Endpoints and Firewall Rules with Windows Azure, Manually setting up OpenVPN in Azure.

    Thanks.


    Wenchao Zeng
    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    • Marked as answer by Wenchao Zeng Monday, August 22, 2011 2:46 AM
    Friday, August 12, 2011 7:03 AM
  • Hi Mapiruli,

    After some searching, I heard that by default JBOSS binds local IP address 127.0.0.1 which is available only for localhost. If we need to allow requests from outside that server machine, we need to bind to IP address 0.0.0.0.

    I am not familiar with JBOSS. So you may want to find a way by yourself to set the binding to 0.0.0.0 instead of 127.0.0.1. Defining an input endpoint and adding a firewall are also necessary steps to expose the web server to public Internet. 

    Thanks.


    Wenchao Zeng
    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    • Marked as answer by Wenchao Zeng Monday, August 22, 2011 2:46 AM
    Monday, August 15, 2011 9:29 AM

All replies

  • Hi Mapiruli,

    To expose the service to outside of Windows Azure, we need to define an input endpoint for the role. An input endpoint will enable load balancer to route requests to role instances. Have you done this step in ServiceDefinition.csdef file?

        <Endpoints>
          <InputEndpoint name="WorkerIn" protocol="tcp" port="8080" localPort="8080" />
        </Endpoints>

    If it still does not work, please also consider it as an firewall issue. If so, you may consider adding a firewall rule via startup task:

    netsh advfirewall firewall add rule name="YourRuleName" dir=in action=allow protocol=TCP localport=<yourport>

    Resources: Internal Endpoints and Firewall Rules with Windows Azure, Manually setting up OpenVPN in Azure.

    Thanks.


    Wenchao Zeng
    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    • Marked as answer by Wenchao Zeng Monday, August 22, 2011 2:46 AM
    Friday, August 12, 2011 7:03 AM
  • I had already defined the endpoint, and I tried to add the firewall rule and it is still not working...

    Any of you have more ideas?

    Thank you very much!!

    Friday, August 12, 2011 2:05 PM
  • Hi Mapiruli,

    After some searching, I heard that by default JBOSS binds local IP address 127.0.0.1 which is available only for localhost. If we need to allow requests from outside that server machine, we need to bind to IP address 0.0.0.0.

    I am not familiar with JBOSS. So you may want to find a way by yourself to set the binding to 0.0.0.0 instead of 127.0.0.1. Defining an input endpoint and adding a firewall are also necessary steps to expose the web server to public Internet. 

    Thanks.


    Wenchao Zeng
    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    • Marked as answer by Wenchao Zeng Monday, August 22, 2011 2:46 AM
    Monday, August 15, 2011 9:29 AM
  • Hi,

    I will mark the reply as answer. If you find it no help, please feel free to unmark it and follow up.

    Thanks.


    Wenchao Zeng
    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    Monday, August 22, 2011 2:46 AM