none
The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine. RRS feed

  • Question

  • Hi Guys,

    I got the below error while connecting the Excel connection in SSIS 2008 R2. Please help on this.

    The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine.

    OS windows Xp professionsl x64 bit

    SQL SERVER 2008 R2 x64 bit

    P.S I have installed Access Engine 12.0 but i still get the error.

    Please advise on it. Thanks

    Thursday, May 17, 2012 5:08 PM

Answers

All replies

  • Did you install the 64-bit version?

    http://www.microsoft.com/en-us/download/details.aspx?id=13255


    Paul ~~~~ Microsoft MVP (Visual Basic)

    Thursday, May 17, 2012 6:15 PM
  • Hi Wood123456,

    Welcome to MSDN Forum.

    Have you tried @Paul's solution? If you have any problems, please feel free to let me know.

    Best Regards


    Allen Li [MSFT]
    MSDN Community Support | Feedback to us

    Monday, May 21, 2012 2:47 AM
    Moderator
  • Install the 64 bit version of the software it'll definatly work

    $Kracker

    Tuesday, May 22, 2012 7:01 AM
  • Hi Allen,

    I have same error as Wood123456 when I just created a new connection with MS access database in VS2010. Even I installed an 64bits AccessDatabaseEngine_x64.exe.

    I still got error of "microsoft ace.oledb.12.0 provider not registered local..." Is anyway that I can check in registry that the  microsoft ace.oledb.12.0 is indeed 64 bits.

    I am using VS 2010 Ultimate version.

    Hope you can help me.

    Roanna

    Friday, June 8, 2012 5:36 AM
  • On 64-bit versions of Windows look for the below paths:

    64-bit - "C:\Program Files\Common Files\Microsoft Shared\OFFICE14\ACEOLEDB.DLL"

    32-bit - "C:\Program Files (x86)\Common Files\microsoft shared\OFFICE12\ACEOLEDB.DLL"  - or -
                "C:\Program Files (x86)\Common Files\microsoft shared\OFFICE14\ACEOLEDB.DLL"


    Paul ~~~~ Microsoft MVP (Visual Basic)

    Friday, June 8, 2012 12:24 PM
  • Hi Paul,

    Thank you so much for such useful hint. I got the version of oledb for office 2010 products. It's 64 bits (in C:\Program Files\Common Files\Microsoft Shared\OFFICE14\ACEOLEDB.DLL) and file version# is 14.0.6015.1000.

    Path "C:\Program Files (x86)\Common Files\microsoft shared\OFFICE14\" doesn't have ACEOLEDB.DLL file.

    However when I tried to create a connection in Visual Studio 2010 (Ultimate) for MS access database, I got above error. Is VS 2010 using 32 bits or 64 bits oledb?

    Roanna

    Friday, June 8, 2012 4:09 PM
  • If you are running 64-bit Windows, the app will run 64-bit if the Platform option (Build...Configuration Manager...) is AnyCPU or x64. If the Platform option is x86 then the app will run 32-bit.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Friday, June 8, 2012 4:49 PM
  • Hi

    Check your MS Application if installed as x64 or 32 bit environment. On Web App Server (IIS Manager) try to change your application pool on advance settings >> Enable 32 bit Application - set True/false then restart the application. On windows app try to publish in x86/64 bit.

    Hope it helps

    Best regards


    To better the Man


    • Edited by Frequent J Friday, September 21, 2012 6:11 AM
    Friday, September 21, 2012 6:03 AM