locked
Symbols not resolving from IDE RRS feed

  • Question

  • I am also having this problem.  The command line generates symbol names in the CSV, but the IDE does not.  It may have to do with the symbol files, but it seems that the does not use the path specified under (Tools - Options - Debugging - Symbols) even though I have specified it.  Furthermore, the symbols are not in any unusual location.  They are with the binaries in the bin\debug path just like they should be.  However, our bin\debug path is not under the project path.  Allow me to explain my scenario in detail:

    I have a directory setup like this:
    C:\...\MasterSolution.sln
    C:\...\ClassLibrary1\ClassLibrary1.csproj
    C:\...\ClassLibrary2\ClassLibrary2.csproj
    C:\...\MainExecutable\MainExecutable.csproj
    etc.  This is a fairly normal setup, except that the output path of the MainExecutable set to "..\bin\Debug\" instead of the default of "bin\Debug\"  The result is that the .PDB files, .EXE files, and .DLL files are in C:\...\bin\Debug instead of C:\...\MainExecutable\bin\Debug.

    Note that I have no problems debugging any of the projects using this setup.  The IDE has no problems launching the application or finding the debug symbols. 

    The .vsp file that is generated when I launch the profiler from the IDE is C:\...\MainExecutable\ which is the project folder, not the output folder.  If I open a command prompt to that location and run vsperfreport, I do not get symbol information.  However, if I run vsperfreport from C:\...\bin\Debug then I do get the symbol information.  If I run vsperfreport from C:\MainExecutable and use the /symbolpath: parameter, it does include the symbols.

    Based on the first couple of replies, I added the symbol path C:\...\bin\Debug to the symbol path under Tools - Options - Debugging - Symbols, but it did not change anything.  It appears to me that when the IDE launches the tool, it does not pass the /symbolpath parameter.  Further, it looks like the IDE incorrectly assumes a location for the PDB files, instead of looking in either the location of the executable, or in the output directory.  Both of those seem like valid ways to find it.

    ----

    In summary, my example has the symbol data located in a customized location, rather than the default, and all functionality in the IDE is able to correctly find the location of the symbols, except for the performace explorer.  I believe this is a bug, and that the prescribed workaround of adding a symbol path does not work.

    My questions are this:
    - Is there another way to specify /symbolpath: so that the IDE will use it?
    - Is there another way to get the IDE to view the resulting output from the tool, so that I can run it manually then see the results?
    Thursday, August 7, 2008 4:15 PM

Answers

  • Hi Moby,

     

    Sorry for the delay.  The profiler should respect the debugger symbol path in Tools -> Options.  Are you adding the exact same path that you passed to vsperfreport /symbolpath?  Have you tried first setting the symbol path in the debugger options and then re-collecting the profiling data?

     

    If you are able to resolve symbols using vsperfreport on the command-line, then you can pack them into the report (.vsp) using /packsymbols, e.g.:

     

    vsperfreport /summary:all /symbolpath:C:\...\bin\Debug /packsymbols MyReport.vsp

     

    Then, you can open this report (with symbols) in the IDE for investigation.

     

    Regards,

    Chris

    Tuesday, August 26, 2008 10:43 PM
    Moderator

All replies

  • Hi Moby,

     

    Sorry for the delay.  The profiler should respect the debugger symbol path in Tools -> Options.  Are you adding the exact same path that you passed to vsperfreport /symbolpath?  Have you tried first setting the symbol path in the debugger options and then re-collecting the profiling data?

     

    If you are able to resolve symbols using vsperfreport on the command-line, then you can pack them into the report (.vsp) using /packsymbols, e.g.:

     

    vsperfreport /summary:all /symbolpath:C:\...\bin\Debug /packsymbols MyReport.vsp

     

    Then, you can open this report (with symbols) in the IDE for investigation.

     

    Regards,

    Chris

    Tuesday, August 26, 2008 10:43 PM
    Moderator
  •  

    I'm assuming that with Chris's response here you were able to solve your issue as there hasn't been a response in a while. I've marked the thread as answered so that we can keep better track of our current issues in the forum.

    If this isn't the case and you're still having issues with this feel free to un-mark the post as answered and give us the details of the problem that you're still running into, specifically any output from vsperfreport /debugsympath.

     

    Thanks,

    Tim

    Wednesday, October 1, 2008 8:10 PM
    Moderator
  • Nahh, I gave up.  I meant for this to be a reply to one of the other posts by someone who had the same problem.  It didn't work for them either, so I did my own profiling. 
    Wednesday, December 31, 2008 2:44 AM