locked
Credential Provider anomaly in windows 10 RRS feed

  • Question

  • Hi all, I have two custom credential providers that I have been developing since Win 8. When I came to up upgrade these CPs for Windows 10, I found some issues. Such as the status messages while connecting not being displayed or the disconnect method being called upon user log in. After a few days of trying to get to the bottom of this, I concluded that this problem was from my implementation and set out to solve it. After a few weeks with no apparent progress, I tried the same CPs on another machine, also running Windows 10. To my utmost surprise the CPs worked flawlessly on this machine, which led me to conclude that the problem lies within the first machine. To verify this I installed the CPs on a third machine, identical to the second one, and it worked again. After this, I tried to identify the differences between the first machine and the other two. They all have the same architecture (x64) but the difference lies within the version and build of Windows 10. The first machine is a Pro Edition Version 10 (Build 10240) while the other machines are Home Edition Version 1607 (Build 14393.187). I do not believe that the Pro Edition has less functionality than the Home Edition, therefore my question is whether there were any bug fixes in Windows 10 builds, as I could not find any details from MSDN or forums. 

    Thanks.

    Tuesday, October 4, 2016 12:57 PM

All replies

  • Hi,

    I have a PLAP Credential Provider that I work on and I have seen similar behaviour under Windows 10.

    Specifically the Disconnect method is called when the user logs into the machine. This is a major problem as our PLAP Credential Provider brings up an encrypted network tunnel, thru an external hardware encryptor, so that the user login credentials are sent over this tunnel. 

    Just like you the behaviour varies from machine to machine. I have had test machines, setup by our support department, that always show the problem, and other machines that never show the problem.

    I have setup test machines myself that never show the problem, or only show the problem about 80% of the time.

    All these machines were running Win 10 Professional or maybe Win 10 Enterprise. There were no Win10 Home versions involved.

    Recently we had a customer who saw the problem and they were using the Win 10 Enterprise N 2015 LTSB (Long Term Service Branch) version. We built a test system using this version and it always shows the Disconnect problem. 

    Win10 LTSB is  10.0.10240

    Currently I am still looking for a solution to this problem.

    Wednesday, April 19, 2017 7:13 AM